Almost There

Discussion in 'Installation/Configuration' started by jacobhenry, Mar 17, 2006.

  1. jacobhenry

    jacobhenry New Member

    I registered my domain at 1&1. They offer "DNS Management".
    First, I registered a domain that I will use for technical issues only, not for web sites or emails ( "DNS Management" was free, so I created an A record that pointed my domain ( to my ip address ( I left the MX record assigned to 1&1. Then I created a subdomain ( and I also pointed this to my ip address ( again leaving the MX record to 1&1. One name server will have to do for now, since I only have one computer running each component of ISPConfig.

    Once everything is settled to my IP address, Will I be able to set up my own domain ( with ISPConfig? And if so what will I use as my A and MX records inside ISPConfig? Does it matter what additional Nameserver I use while configuring my domain ( inside 1&1?

    I am also concerned with my /etc/resolv.conf file. Is there anything wrong?

  2. falko

    falko Super Moderator Howtoforge Staff

    Yes, but you must tell your registrar that is the authoritative name server for

    Simply create a zone "", and as A records you create "www" and "mail", and regarding the MX record, you leave the host name blank and enter as mail server.

    Maybe you can put in twice?

    Yes: You must always use IP addresses as name servers in /etc/resolv.conf! Like this:

    You shold also have a look here: and here: to get a deeper understanding how this DNS thing works.
  3. jacobhenry

    jacobhenry New Member

    Could someone IM me to help me set up a domain inside the ISPConfig Interface. My aim screenname is CUB2004VA . I am just digging myself a hole.

    I have my (hosting) domain name pointing to my IP address which allows me to log onto ISPConfig just fine. I don't understand how ISPConfig will know the difference between my hosting domain and any other domain if they are both just pointing to my IP address? And what was the purpose of configuring a second ip address in the perfect setup?

    Last edited: Mar 18, 2006
  4. jacobhenry

    jacobhenry New Member

    I have a hard time explaining in words the problems I am having so I am going to explain it with pictures.

    First I will create a 'New Site' and then go to the Records it creates automatically

    Here I chose to have ISPConfig Create DNS and Create DNS-MX Records


    Then I added the Co-Domains for and


    After filling out all the information for the 'New Site' I went over to the 'DNS Manager' tab and a new record for was created.

    The second tab 'Options' had a spot for two nameservers which confuses me. I used's 'DNS Management' to use my own nameserver so what values would I use for the nameservers in ISPConfig?


    The last tab 'Record' also confused me. The A Records looked fine assuming the private IP addresses are ok.


    but the MX Record used instead of Is this correct? if not what do i need to change in order for it to create the MX Record using the domain I am setting up?

  5. falko

    falko Super Moderator Howtoforge Staff

    Fill in your own name server(s) here (the ones that are authoritative for the domain).

    You must use public IP addresses here, otherwise nobody from outside your LAN can access the domains.

    As long as and point to the same IP address, it doesn't matter which one you specify. But I'd take
    You must also create an entry with as mailserver and an empty hostname if you want to receive emails for [email protected].
    Your current MX records allow you to receive emails for [email protected] and [email protected].

    ISPConfig creates an Apache configuration that is based on name-based vhosts, i.e. you type a domain name in your browser, and Apache sees that domain name and decides which web site it must serve.

    That is totally optional. It's just an example how you do it if you need another IP address.
  6. jacobhenry

    jacobhenry New Member

    These are the final settings I used for my records to get the website to work.


    Three more questions:
    1)How do individual sites connect to there files with a FTP client? (site? username? password?)
    2)How do individual sites connect to there databases using PHPMyAdmin? (username? password?) (I was unable to log in using the usernames I created)
    3)How do individual sites use webmail? (I have not been able to log in with the usernames I set up with the website? I am new to hosting my own email, so where should I start to research and test Postfix?)
    Last edited: Mar 18, 2006
  7. falko

    falko Super Moderator Howtoforge Staff

    Use an FTP client like SmartFTP or WS_FTP. As hostname you can use any FQDN or IP address that points to the server, typically you'd use a domain of the web site. The username is the username of the site admin you created under "User & Email" (e.g. web1_adminuser).

    In ISPConfig you create databases under the "Options" tab. There you also see the username of the database, typically something like web1_u1 (that would be the username for the database web1_db1).

    The ISPConfig webmail package behaves different than an email client. In an email client you must use the username (e.g. web1_someuser), whereas in webmail you must use an email address as username to log in.
  8. jacobhenry

    jacobhenry New Member

    I have just found out that my Nameservers are not set up correctly. I will try to explain all the steps that I took hoping you can catch my error.

    1) First I created and aimed it towards my IP address. ( successfully leads me to my ISPConfig login)

    2) Then I created two subdomains ( and ( I used's DNS servers and again aimed both of these nameservers to my IP address, which is hosting ISPconfig.


    3) Since I had two of my own nameservers, I changed the Settings>DNS default nameservers to ns1... and


    4) I created a 'New Site' under ISP Manager with the domain

    5) Under DNS Manager>Options, both the nameservers are set to my default nameservers ( and

    6) Under DNS Manager>Records are the following records.


    7) As soon as i created the records in ISPConfig, I changed the default nameservers for on's site to:


    Do you have any suggestions or solutions for my problem? I know I have been a pain in the butt, but i really enjoy using ISPConfig to learn about linux and web hosting. I appreciate your feed back and support.
  9. falko

    falko Super Moderator Howtoforge Staff

  10. jacobhenry

    jacobhenry New Member

    Its only working because I changed the settings in 1and1 to use their NS and point the domain back to my IP. is still set up using my name servers and it does not work. Sorry about switching it on you. Under Management>Services>Services it shows everything working properly. Is there any other way to test my DNS to make sure its working properly?

    In the /etc/resolv.conf file

    By default it put my internet service provider. Should I have changed it to my domain or kept it at the default value?
    Last edited: Mar 19, 2006
  11. falko

    falko Super Moderator Howtoforge Staff

    You can test with dig:

    dig @localhost
    Looks ok.
  12. jacobhenry

    jacobhenry New Member

    I have done multiple tests to make sure my dns server is alright, which it is. So now I have to find out why my nameservers are not being recognized.

    Here I tested my localhost to detect the nameserver, and assure the domain ( was in my records.

    Then I tested both of my Name Servers to make sure they were both pointing to my IP.

    Now when I check the domain outside of my local host I get this:

    and these are the settings I have for this domain with my registrar


    So the problem could be that I try to use both nameservers on one machine.

    I can not find why my box is not responding. Any additional suggestions?
  13. falko

    falko Super Moderator Howtoforge Staff

    I tried your nameserver and got this:

    ; <<>> DiG 9.2.1 <<>>
    ;; global options:  printcmd
    ;; connection timed out; no servers could be reached
    Either BIND is not running, or your firewall is blocking port 53.

    BTW, you shouldn't let point to a local IP address because then nobody from outside your LAN can access it.
  14. jacobhenry

    jacobhenry New Member

    Got it working. Thanks for your patience falko.
    Last edited: Mar 21, 2006
  15. jacobhenry

    jacobhenry New Member

    Now I am on to my final task - Getting the Email to work properly. I have used the perfect setup for Debian Sarge and am having troubles while sending emails. Everything worked great when I sent an email to my account but I continue to get undelivered emails when I try to send from webmail. This could possibly be because I am behind a router that does not allow for loopback, but I will post my mail.log just incase that is not the problem.

    Mar 22 13:17:23 server1 postfix/smtpd[18682]: connect from localhost.localdomain[]
    Mar 22 13:17:23 server1 postfix/smtpd[18682]: 97B7C23EEF: client=localhost.localdomain[]
    Mar 22 13:17:23 server1 postfix/cleanup[18685]: 97B7C23EEF: message-id=<[email protected]>
    Mar 22 13:17:23 server1 postfix/qmgr[7447]: 97B7C23EEF: from=<[email protected]>, size=1309, nrcpt=1 (queue active)
    Mar 22 13:17:23 server1 postfix/smtpd[18682]: disconnect from localhost.localdomain[]
    Mar 22 13:17:23 server1 courierpop3login: Connection, ip=[::ffff:]
    Mar 22 13:17:23 server1 courierpop3login: LOGIN, user=web8_jacobhenry, ip=[::ffff:]
    Mar 22 13:17:23 server1 courierpop3login: LOGOUT, user=web8_jacobhenry, ip=[::ffff:], top=0, retr=0, time=0
    Mar 22 13:17:39 server1 postfix/smtp[18687]: 97B7C23EEF: to=<[email protected]>, relay=none, delay=16, status=bounced ([]: Name or service not known)
    Mar 22 13:17:39 server1 postfix/cleanup[18685]: E169523EF0: message-id=<[email protected]>
    Mar 22 13:17:39 server1 postfix/qmgr[7447]: E169523EF0: from=<>, size=3133, nrcpt=1 (queue active)
    Mar 22 13:17:39 server1 postfix/qmgr[7447]: 97B7C23EEF: removed
    Mar 22 13:17:40 server1 postfix/pickup[16687]: 0C1B123EEF: uid=10008 from=<web8_jacobhenry>
    Mar 22 13:17:40 server1 postfix/cleanup[18685]: 0C1B123EEF: message-id=<[email protected]>
    Mar 22 13:17:40 server1 postfix/qmgr[7447]: 0C1B123EEF: from=<[email protected]>, size=402, nrcpt=1 (queue active)
    Mar 22 13:17:40 server1 postfix/local[18706]: 0C1B123EEF: to=<admispconfig@localhost>, relay=local, delay=0, status=sent (delivered to command: /usr/bin/procmail -f-)
    Mar 22 13:17:40 server1 postfix/qmgr[7447]: 0C1B123EEF: removed
    Mar 22 13:17:41 server1 postfix/local[18697]: E169523EF0: to=<[email protected]>, orig_to=<[email protected]>, relay=local, delay=2, status=sent (deli$
    Mar 22 13:17:41 server1 postfix/qmgr[7447]: E169523EF0: removed
  16. till

    till Super Moderator Staff Member ISPConfig Developer

    Your server seems to be unable to resolve external domains.

    Please check the file /etc/resolv.conf if the nameservers in there are correct.
  17. jacobhenry

    jacobhenry New Member

  18. falko

    falko Super Moderator Howtoforge Staff

Share This Page