Amavis setup problem

Discussion in 'Installation/Configuration' started by Duncan Me, May 12, 2022.

  1. Duncan Me

    Duncan Me New Member

    When I try to install amavisd I get an error

    RSA.xs:194: OpenSSL error: no start line at (eval 95) line 75.

    I have tried uninstalling and reinstalling and just get the same error. I have gone through reinstall and checked every forum I can but can not find anything to do with this error. I have run the test script and found nothing appart from amavisd not started.

    Job for amavis.service failed because the control process exited with error code.
    See "systemctl status amavis.service" and "journalctl -xe" for details.
    invoke-rc.d: initscript amavis, action "start" failed.
    ‚óŹ amavis.service - LSB: Starts amavisd-new mailfilter
    Loaded: loaded (/etc/init.d/amavis; generated)
    Active: failed (Result: exit-code) since Thu 2022-05-12 09:06:23 UTC; 16ms ago
    Docs: man:systemd-sysv-generator(8)
    Process: 224903 ExecStart=/etc/init.d/amavis start (code=exited, status=1/FAILURE)

    May 12 09:06:22 eskia.uk systemd[1]: Starting LSB: Starts amavisd-new mailfilter...
    May 12 09:06:23 eskia.uk amavis[224903]: Starting amavisd:
    May 12 09:06:23 eskia.uk amavis[224910]: RSA.xs:194: OpenSSL error: no start line at (eval 95) line 75.
    May 12 09:06:23 eskia.uk amavis[224903]: (failed).
    May 12 09:06:23 eskia.uk systemd[1]: amavis.service: Control process exited, code=exited, status=1/FAILURE
    May 12 09:06:23 eskia.uk systemd[1]: amavis.service: Failed with result 'exit-code'.
    May 12 09:06:23 eskia.uk systemd[1]: Failed to start LSB: Starts amavisd-new mailfilter.
    dpkg: error processing package amavisd-new (--configure):
    installed amavisd-new package post-installation script subprocess returned error exit status 1
    Errors were encountered while processing:
    amavisd-new


    Thanks very much,
    This is my first time posting I hope I have not offended anyone.
     
  2. Taleman

    Taleman Well-Known Member HowtoForge Supporter

    You do not say which Linux distribution and which version you are using.
    How are you installing amavis? Are you installing from the distribution repository or from somewhere else?
    The error message is strange. Try to find which file it is about, and verify the file looks correct. It probably is a text file so you can just read it. Check the line endings are Linux line endings and file does not have extra stuff.
    What did you do up to starting installation of amavis?
     
  3. Duncan Me

    Duncan Me New Member

    Hello,

    thanks so much for replying,

    Ubuntu 20.04.4 LTS
    we have installed using the https://www.howtoforge.com/tutorial...l-pureftpd-bind-postfix-doveot-and-ispconfig/ guide.
    We started with a clean install and followed the guide.

    We are really struggling to find which file it is complaining about it is not mentioned in any logs the error suggests it is a SSL certificate in the wrong format but not entirely sure which certificate we could fix a certificate error.

    Thank you so much looking forwards to your responce

    Duncan
     
  4. Taleman

    Taleman Well-Known Member HowtoForge Supporter

  5. Duncan Me

    Duncan Me New Member

    Thanks for the quick reply we believe we have just got it working.
    We nuked it using
    dpkg --purge --force-all amavisd-new
    dpkg --purge --force-all amavis
    apt purge amavisd-new
    apt autoremove
    dpkg --purge --force-all amavisd-new

    then reinstalled and now it is start ok. Just now got a small port issue. Now we go that working we should be able to fix the port issue.

    Thank you so much for your help
    Duncan
     

Share This Page