Amavisd Failed

Discussion in 'Installation/Configuration' started by Jacbey, Dec 14, 2015.

  1. Jacbey

    Jacbey New Member

    I installed using the perfect server guide in june time. In mid october amavisd suddenly stopped working when my server went down (host reasons of which to this day I am still unsure about)
    I get this error:

    Does anyone have any idea of what the hell I need to do because I've been stuck on this for ages and I'm not finding any solutions.
    I have tried uninstalling amavisd, reinstalling it and updating ispconfig and reconfiguring services. I've made sure that my hostname is correct. All of this is to no avail.
    Please help, I'm becoming desperate! None of my emails will come in or go out because of this and have had to get an external mail server to do the job for my clients because of this! :(

    *Update* i've got mail working again by disabling amavis in postfix, however still no change on actually getting postfix to work. Still need help :( */*
    Last edited: Dec 14, 2015
  2. This used to be a bug with an old version of amavis but should be fixed right now. However an hostname or defining a valid FQDN is mandatory for amavis. Have you setup:
    If not, you will have to configure these, then restart amavis and try again. If you do, then please try the following fix and change the commented to the non-commented:
    # cd /etc/amavis/conf.d
    #cat cat 05-domain_id
    #chomp($mydomain = `head -n 1 /etc/mailname`);
    chomp($mydomain = "your.mailname.come");
    #cat 05-node_id
    #chomp($myhostname = `hostname --fqdn`);
    chomp($myhostname = " --fqdn");
    Please output what you got, and ask anything more if you got any questions.

    Also see if any of these directories are world writable:
    ls -ld /
    ls -ld /usr
    ls -ld /bin
    ls -ld /sbin
    ls -ld /usr/bin
    ls -ld /usr/sbin
    ls -ld /usr/local
    ls -ld /usr/local/bin
    ls -ld /usr/local/sbin
    This could cause the insecure directory problem. When one of these for example have a 777 permission set.
  3. Jacbey

    Jacbey New Member

    Thanks CrypticDesigns, but I gave up and reinstalled the whole server. I'm now using VestaCP which granted comes with its own flaws but was nowhere near as ridiculous to setup and maintain. I promised myself I would do this next time something screwed up or ISPConfig messed itself over and so far it's been a lot better.

    Thanks again, I'll definitely keep your answer in mind if I ever run into the same problem again.

    P.S I'm fairly sure the fqdn was fine but hey ho :)

Share This Page