Apache stop working

Discussion in 'Installation/Configuration' started by pecka33, Sep 24, 2023.

  1. pecka33

    pecka33 Member

    Thank you all for the advice.
    I've been fighting this all night, comparing everything.
    I don't see the difference, for example, in fstab from when it was in the advice and from that backup. But when I do df h, I see that one connected disk is missing compared to the drive that was there and I don't know why. I tried to mount manually, then I saw it in df among the disks, but it disappeared after rebooting.

    At the same time fstab remains the same.

    I have already edited it, I added some other paths to the directories that were missing. By default, I have two disks, each with a size of 1 TB. I direct one sda to / and the other sdb1 pointing to /var. Don't ask why it's so bad. I would say that this is the problem.

    I just don't know where, I've tried everything possible, I have some client websites on it and it's all burning, but I don't know anyone in this field who would look at it. Someone told me that it could be a disk, but I don't think so, writing to the disk and loading is fine.
    I have the latest version, several years old including Debian. Everything was always ok. Unfortunately, some changes were made in ispconfig thanks to the client in apache and it crashed. I tried everything. Services always started after one reboot, but port8080 did not work for some reason, after another reboot services such as clamav and php 5.6-.8.2 failed, sometimes only one php was down. When I fixed everything and nothing was failed, it still failed.

    So I decided on data recovery. ISPCONFIG performs regular data backups, specifically acme for lets encrypt, the entire ispconfig directory and then the entire /etc directory including the entire configuration. So I took a backup from 1:00 p.m. yesterday, when everything was fine, uploaded it, rebooted, and from then on, the server started behaving strangely and even collapsed. I've gone through the logs several times, but my server has never crashed like this and I'm at a loss. The worst thing is that I can now access the server management only through the HPE ilo panel, and it works very limited, in terms of speed, very slowly.

    After the reboot, I can see the above, fstab is still the same, but when I put df h, I can't see the drive for /var that was there. Even after mounting and restarting, they disappear again. The network probably doesn't work either, I can't get there through classic putty and dig doesn't respond / host not found.

    These are the logs I managed to get.

    Some errors i get

  2. pecka33

    pecka33 Member

    I solved it. Server is working now, SSH, i can get my files, websites..

    I did sudo fsck -y /dev/disk for mounted disk, after reboot start working services.

    But not apache, i get

    Any idea please?
    ● clamav-clamonacc.service  loaded failed failed ClamAV On-Access Scanner
    ● named.service             loaded failed failed BIND Domain Name Server
    ● php7.3-fpm.service        loaded failed failed The PHP 7.3 FastCGI Process Ma>
    ● php7.4-fpm.service        loaded failed failed The PHP 7.4 FastCGI Process Ma>
    ● php8.1-fpm.service        loaded failed failed The PHP 8.1 FastCGI Process Ma>
    ● redis-server.service      loaded failed failed Advanced key-value store
    ● roundcube-cleandb.service loaded failed failed Purge Roundcube database: remo>
    LOAD   = Reflects whether the unit definition was properly loaded.
    ACTIVE = The high-level unit activation state, i.e. generalization of SUB.
    SUB    = The low-level unit activation state, values depend on unit type.
    7 loaded units listed.
  3. pecka33

    pecka33 Member


    most probably i found problem. I found that there are no symlinks in folder /etc/apache2/sites-enabled, there should be symlinks from sites availible i guess? How can i fix it?
  4. Taleman

    Taleman Well-Known Member HowtoForge Supporter

    Restore directory contents from backups.
    Or create the symlinks manually, the command is a2ensite. Read man a2ensite.
    Or if you are using ISPConfig, I think resync would create the symlinks. ISPConfig Panel, Tools, Sync Tools, Resync and tick on websites.
    If I were you, I would install a new ISPConfig system, properly set up and configured, then use Migration Tool to copy the data from the old seemingly hopelesly messed up system to this new known good ISPCOnfig system.
  5. pecka33

    pecka33 Member

    Thank you. As you wrote, most probably will be reinstall complete server.

    But what about backups? I can not get to ispconfig, only to sftp server. Is here way to to backups all from /var/www/ and do new install of isp, do the same websites and upload it?

    And what about database? Should i create it and import or can i download mysql from lip directory and upload to new server via sftp?
  6. Taleman

    Taleman Well-Known Member HowtoForge Supporter

  7. pecka33

    pecka33 Member

    Yes, i saw it. I guess you have to access to present ispconfig, but in case i can not access, i can not use this tool.
    So i think that best will be Backup all data, var/www, v mail, mysql sítě databases in new folder and reinstall and Configure server.

    At all, afrer all changes I did on page with port 8080 where should be ispconfig, phpmyadmin etc. I have SSL right now, but I see only forbidden.
    On other page looks like i have not ssl and page without HTTPS show standard debian page. I tried all your advice include reconfigure ispconfig and reload symlinks.
    I think that this should be prohlem with php pool sock, but not sure.

    Services which failed now are

    UNIT                        LOAD   ACTIVE SUB    DESC>
    ● apache-htcacheclean.service loaded failed failed Disk>
    ● clamav-clamonacc.service    loaded failed failed Clam>
    ● named.service               loaded failed failed BIND>
    ● php8.1-fpm.service          loaded failed failed The >
    ● redis-server.service        loaded failed failed Adva>
    ● rspamd.service              loaded failed failed rapi>
    ● unattended-upgrades.service loaded failed failed Unat>
    can not found why. But in case i change nameservers from Default to named service start working.
  8. Taleman

    Taleman Well-Known Member HowtoForge Supporter

    There is ISPConfig Business Support if you are willing to pay to get the system fixed. https://www.ispconfig.org/support/
    You could ask for a quote for the price, but it may be your system is really messed up and getting it fixed is hard.

Share This Page