Apache2 undefined symbol: gzopen64

Discussion in 'Installation/Configuration' started by PhilyWisk, Apr 30, 2008.

  1. PhilyWisk

    PhilyWisk New Member

    Hi, I have had the following problem twice now.

    The first time I assumed it was because I installed webmin on top of ISPconfig but this time I have kept the install clean and not tried webmin.

    I was logged in through ssh and restarted apache2:

    [email protected]:~# /etc/init.d/apache2 restart
    * Restarting web server apache2
    * We failed to correctly shutdown apache, so we're now killing all running apache processes. This is almost certainly suboptimal, so please make sure your system is working as you'd expect now!
    apache2: Syntax error on line 183 of /etc/apache2/apache2.conf: Syntax error on line 1 of /etc/apache2/mods-enabled/php5.load: Cannot load /usr/lib/apache2/modules/libphp5.so into server: /usr/lib/libxml2.so.2: undefined symbol: gzopen64
    I followed the Perfect Server on Ubuntu howto exactly.

    Please note I have solved this solution. Using advice from https://bugs.launchpad.net/ubuntu/+source/libxml2/+bug/151045
    (i.e I removed /usr/local/lib/libz* and restarted apache2) but I was interested to know what the issue was.
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    I guess you complied a libz version manually with the wrong compile options in the past, as the default libz is not installed in /usr/local/lib/
  3. PhilyWisk

    PhilyWisk New Member

    Hi till, thanks for your reply but as I said I followed the tutorial line by line. The only other thing I have installed on this server is cups...and everything I have installed has been through aptitude. (except the ISPconfig install which was the install.sh script)

    Do you think the gzopen64 is specific for 64 bit systems? My system is 32 bit.
  4. PhilyWisk

    PhilyWisk New Member

    Oh yeah, forgot to mention.... I have been trying to replicate what might have happened to cause this error with no luck.
  5. falko

    falko Super Moderator ISPConfig Developer

    So it's working now?
  6. PhilyWisk

    PhilyWisk New Member

    Yes, the reason I asked was to note down the solution in case anyone else out there has the same problem & also to try and figure out what I did to cause this error (still can't replicate it).

    As I said, it's not important, it's just I'm interested in what went wrong!


Share This Page