APS crawler: String could not be parsed as XML

Discussion in 'Installation/Configuration' started by VANKO, Mar 19, 2015.

  1. till

    till Super Moderator Staff Member ISPConfig Developer

    This patch is not for, so don't apply it as it will break your server. The issue handled in this patch has been solved in so no patch is required.

    I just tested the aps package list update here and it works fine in Do you get any errors on the screen or in the ispconfig system log in the monitor?

    Thats possible as it may contain old package versions.
  2. Hello,
    I only have a warning in the editor and the 3054 patch doesn't install which is good and kudos to the folks who wrote the patch routine.

    This is the error that I get.

    1. String could not be parsed as XML
    This is the warning in the monitor.
    1 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
    Inst libexpat1 [2.1.0-4ubuntu1] (2.1.0-4ubuntu1.1 Ubuntu:14.04/trusty-updates [amd64])
    Conf libexpat1 (2.1.0-4ubuntu1.1 Ubuntu:14.04/trusty-updates [amd64])

    upgrading libexpat1 did not solve the problem.

    Last edited: Sep 1, 2015

    RHITNL Member

    The only error I have since a couple of weeks is
    [INTERFACE]: APS crawler: Cannot read metadata from AfterLogic WebMail Lite-7.5.0-1.app.zip
    Installing an app works perfectly so no problem for me.
  4. till

    till Super Moderator Staff Member ISPConfig Developer

    This error just means that the zip file of this one package is broken, either at apscatalog or the downloaded file on your server.
  5. Good evening. I finally got around to looking at this again. I have a virtual machine running on virtual box that has the same setup as my production server. I had to update it to the latest release, but then I updated the APS package list and it worked fine. The testing VM populated about 5 and half pages of packages. *Well* that made me go back and look at the production server. As near as I could tell there must have been something corrupted in the "/interface/web/sites/aps_meta_packages" directory. Who knows which one? So I navigated to the folder and ran "sudo rm -rf *.zip" I then went back to the APS installer and ran the update package list and this time it ran without error. Problem solved.
    redb likes this.
  6. redb

    redb New Member

    SUPER MANY THANKS. Its possible to erase all the .zip files by hand since ftp

Share This Page