AWStats error.

Discussion in 'Installation/Configuration' started by karuott, Dec 15, 2011.

  1. karuott

    karuott New Member


    I'm having problem with awstats. It doesn't create /stats/awsindex.html file.
    And because of that i'll get 404 error page.
    Is there any solution to fix that problem?

  2. till

    till Super Moderator Staff Member ISPConfig Developer

    Check that the paths to the awstats scipts in System > Server config match the paths on your system.
  3. Member

    Do I have to install awstats first? Or is it installed with ISPConfig?

    I did locate awstats, but could not locate any file except


    I did yum install awstats, it installed aw, geoip, and perl-Geo-IP. Hope it will work now.

    Do I have to make any changes in httpd conf files?

  4. karuott

    karuott New Member

    Weird. I changed paths but still it doesn't create that html file. In stats folder I have index.php and .htaccess. Awstats doesn't create any log files and there isn't any errors in apache errorlogs. I'm really stuck here :(

    Ok. I found the problem searched awstats.conf but i had awstats.web.conf instead.
    Last edited: Dec 16, 2011
  5. Member

    HI ...

    I am also having same problem.

    All paths are set in server config, awstats installed using yum..

    Any other change we have to do?

    Please ... webalizer works fine, but it does not show all search results.

  6. Member

    I can see a file


    It has all data for all domains, how can I separate it for each domain?

    Do I need to create conf files for each domain?

  7. Member

    I am getting 500 Internal server error when I check /stats/

    I am unable to locate the error.

    This started after I enable awstats ....

    What is the way to run awstats manually?
  8. till

    till Super Moderator Staff Member ISPConfig Developer

    Have you set a statistics password on the stats tab of the website settings?



    as root user
  9. Member

    running ...

    Have a password already since I was running webalizer for over a year. It was eating most of the search strings, hence thought of switching to awstats ..

    the warning is as follows

    [root@linode web]# /usr/local/ispconfig/server/
    [new_unode] Warning: String exceeds storage size (1158)

    Warning: rename(/var/www/clients/client1/web1/web/stats/,/var/www/clients/client1/web1/web/stats/awsindex.html): No such file or directory in /usr/local/ispconfig/server/cron_daily.php on line 240

    Warning: rename(/var/www/clients/client15/web15/web/stats/,/var/www/clients/client15/web15/web/stats/awsindex.html): No such file or directory in /usr/local/ispconfig/server/cron_daily.php on line 240
  10. Member

    I changed the site PHP mode to modPHP from suPHP, that solves the Apache 400 error .. but it still not creating the statsfile in /stats directory
  11. Member

    Ok ok .. works fine now.

    I did cp awstats.model.conf awstats.conf

    works well now.. thank you Till ...

Share This Page