Awstats not working with nginx on debian with lets encrypt

Discussion in 'Installation/Configuration' started by LAKSHA, Apr 2, 2017.


    LAKSHA Member

    I had used
    and now while setting up password of awstat and using it to login . i get 404 error on https://mydomain.tld/stats i also tried it without https and it gives the same error .
    I do see the build static page pl file at /usr/share/awstats/tools and i do see stats folder inside the web folder of my tld.
    awstats conf folder /etc/awstats
    awstats data folder /var/lib/awstats script /usr/lib/cgi-bin/ script /usr/share/awstats/tools/
    following is my wp-config
    define('FORCE_SSL_ADMIN', true);

    /* That's all, stop editing! Happy blogging. */
    /** Absolute path to the WordPress directory. */
    if ( !defined('ABSPATH') )
    define('ABSPATH', dirname(__FILE__) . '/');
    /** Sets up WordPress vars and included files. */
    require_once(ABSPATH . 'wp-settings.php');
    define( 'WP_ALLOW_MULTISITE', false );
    define ('FS_METHOD', 'direct');
    in my ispconfig for mydomain.tld there is not redirect rule or a box checked for redirect from http to https.

    Any help will be highly appreciated and endorsed

    LAKSHA Member

    I do see all the stats files in stat folder and all the web traffic in ispconfig 3 panel but when i open the stats and use my passwords it just loads the main frame and the inner frame does not load and throws 404 error. :-( sos to @till :confused: please help

    LAKSHA Member

    i changed the path to access log in the awstat.domain.tld.conf file here /etc/awstats but still cannot see the stats

Share This Page