Bind not working

Discussion in 'Installation/Configuration' started by radioguy, Aug 15, 2005.

  1. radioguy

    radioguy New Member

    I noticed my Bind-server is off line. I just noticed it, so I'm not sure how it was broke or if it is. When I restart named, I get this message.

    Aug 15 08:29:19 server named: /etc/named.conf:5: change directory to '/var/named/chroot/var/named' failed: file not found
    Aug 15 08:29:19 server named:
    Aug 15 08:29:19 server named: /etc/named.conf:5: parsing failed

    Thanks for your help.
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    Is the file /etc/named.conf there?
  3. radioguy

    radioguy New Member

    Yes its there here are the contents:

    options {
    pid-file "/var/named/chroot/var/run/named/";
    directory "/var/named/chroot/var/named";
    auth-nxdomain no;
    * If there is a firewall between you and nameservers you want
    * to talk to, you might need to uncomment the query-source
    * directive below. Previous versions of BIND always asked
    * questions using port 53, but BIND 8.1 uses an unprivileged
    * port by default.
    // query-source address * port 53;

    // a caching only nameserver config
    zone "." {
    type hint;
    file "";

    zone "" {
    type master;
    file "named.local";

    zone "" {
    type master;
    file "";

    zone "" {
    type master;
    file "";

  4. falko

    falko Super Moderator Howtoforge Staff

    I guess the directory /var/named/chroot/var/named is missing?
  5. radioguy

    radioguy New Member

    Actually, it is there. Here are the contents:

    chroot named.broadcast named.ip6.local slaves
    data named.local pri.https:
  6. falko

    falko Super Moderator Howtoforge Staff

    I think this has to do with the fact that your Bind is running chrooted. Maybe some symlink that's missing... :confused:
  7. radioguy

    radioguy New Member

    It's fixed

    I had a file permission problem. All is good now.
  8. silviuchingaru

    silviuchingaru New Member

    How did u solved? because I'm haveing the same problem...
  9. Simulacra

    Simulacra New Member

    Same Issue

    I have run into the same issue. It does seem to be a permissions issue with the chroot jail. No response from the poster, so if anyone has any information I would greatly appreciate your help.

  10. Simulacra

    Simulacra New Member

    Successful Fix

    I ventured back to the manual. Although everything was done properly during the installation, for some reason the permissions set for Named did not stay. I simply chmod'd the directories as the guide instructed and Bind was working again.

  11. fobicodam

    fobicodam New Member

    Doesnt work for me !

    i tried that and still getting the cant find file error... i knew linux was unestable but not that much !!!! how can i fix it ?!??! please !!!! 5 minutes testing it and it just fall with no reason !!!! :mad:
  12. falko

    falko Super Moderator Howtoforge Staff

    Do you have any errors in your log files or when you restart BIND?
  13. 22hosting

    22hosting New Member

    If you are working in a CHROOT'd environment you need to make sure that it has access to certain files outside that directory. At a guess I would say you need to make this directory available : /var/named/chroot/var/named
    Live Sex
    Last edited: Aug 22, 2011

Share This Page