cannot chmod (change owner of folder) ?

Discussion in 'Technical' started by Ovidiu, Oct 23, 2005.

  1. Ovidiu

    Ovidiu Active Member

    cannot chown (change owner of folder) ?

    I just noticed a typo in the post title: it should say: chown instead of chmod

    I did a ls -al inside my /var/www and this is part of the result:

    I tried a
    which is the default settign as it should be. The comand is executed but there is no change. Still the same settings like above. I am logged in as a user and then did a sudo su to get root powers...

    can anyone suggest how to get rid of this problem?

    btw. spamd is a user I made for a local version of spamassassin running for another task, but I am sure I never gave that user rights to this folder...

    I found a log entry that seems connected to this:

    very strange - one of the accounts below the falsely spamd-owned folder can access mail (he is the admin of the site) but another user here you can see web14_a1 cannot...
    Any ideas? I'd like to solve this in an elegant matter not just by deleting the domain from ispconfig and from cache and then recreating...
    Last edited: Oct 23, 2005
  2. falko

    falko Super Moderator Howtoforge Staff

    Can you have a look at /etc/passwd and check if web14_postmaster and spamd have the same user id? If so, you should change spamd's user id to a value that's not in use and not in the range of ids used by ISPConfig (by default, user ids in ISPConfig start at 10000).
  3. Ovidiu

    Ovidiu Active Member

    that did the magic trick - thx a lot

Share This Page