Cannot connect to anonymus ftp

Discussion in 'Installation/Configuration' started by n1kol1s, Jul 4, 2006.

  1. n1kol1s

    n1kol1s New Member

    Thats what im doing .As i said before i can access the users ftp with no problems at all and super charged speeds.. the problem is that it is asking me for a password for the anonymus user.

    [18:30:57] SmartFTP v2.0.996.25
    [18:30:57] Resolving host name ""
    [18:30:57] Connecting to Port: 21
    [18:30:57] Connected to
    [18:30:57] 220 Welcomme to my Ftp Server. Enjoy!
    [18:30:57] USER anonymous
    [18:30:57] 331 Password required for anonymous.
    [18:30:57] PASS (hidden)
    [18:30:57] 530 Login incorrect.
    [18:30:57] Active Help:
    [18:30:57] Cannot login waiting to retry (30s)...

    were I could posibbly find error logs for proftpd , i looked at /var/log/proftpd but there is nothing in there.
    Last edited: Jul 20, 2006
  2. falko

    falko Super Moderator ISPConfig Developer

    What's the output of
    grep anonftp /etc/password
    grep anonftp /etc/group
  3. n1kol1s

    n1kol1s New Member

    I think now we are getting

    [[email protected] ~]# grep anonftp /etc/password
    grep: /etc/password: No such file or directory

    [[email protected] ~]# grep anonftp /etc/group
    [[email protected] ~]#

  4. falko

    falko Super Moderator ISPConfig Developer

    I'm sorry, the command is
    grep anonftp /etc/passwd
  5. n1kol1s

    n1kol1s New Member

    That's Better.

    [[email protected] ~]# grep anonftp /etc/passwd
    [[email protected] ~]#
  6. falko

    falko Super Moderator ISPConfig Developer

    You only have web9_anonftp in /etc/passwd? What about web12_anonftp, etc.?
  7. n1kol1s

    n1kol1s New Member

    I have manualy removed the web12 and any other i have created whille testing and i left only the web9_anonftp .i dont need the others for the time beeng. I wanna focus on one anonymus user account and thats the web9.
    Still same problem , user web9_nikolis password protected is working but anonymus is not.

  8. till

    till Super Moderator Staff Member ISPConfig Developer

    Never remove anything manually from the ISPConfig database, you will corrupt your setup if you dont delete the related records in the isp_dep and isp_nodes tables too!

    Do you get any error messages if you restart your ftp daemon?
  9. n1kol1s

    n1kol1s New Member

    No no errors at all...
    Before i removed the other anonymus ftp accounts I untick the anonymus ftp related box from each unwanted accounts.
  10. falko

    falko Super Moderator ISPConfig Developer

    How did you remove them? By editing the MySQL databse, or on the shell?
  11. n1kol1s

    n1kol1s New Member

    I vi from shell /etc/passwd and remove them. im not touchinf mysql..too scared . lol
  12. falko

    falko Super Moderator ISPConfig Developer

    Did it work before you did this?
  13. n1kol1s

    n1kol1s New Member

    never worked m8....
    i reinstall the perfect setup fc5 a couple of times before and even then i had the same problem. everything else is working llike a dream.
  14. falko

    falko Super Moderator ISPConfig Developer

    Then I have no idea what's wrong...
  15. n1kol1s

    n1kol1s New Member

    ohhh....ok . Thanks for your help anyway. much arpeciated...
    Ill download another copy of fc5 and reinstall the lot.
    is there a unantended ks file with all the perfect fedora core 5 32bit setup settings?
  16. falko

    falko Super Moderator ISPConfig Developer

    What's a ks file?
  17. n1kol1s

    n1kol1s New Member

    Something like this...i bet you seen this

    # Kickstart file automatically generated by anaconda.

    lang en_US.UTF-8
    keyboard us
    xconfig --driver "sis" --videoram 16384 --resolution 800x600 --depth 16
    monitor --hsync 31.5-37.9 --vsync 50-70
    network --device eth0 --bootproto dhcp --hostname
    rootpw --iscrypted $yourincryptedpassword.
    firewall --disabled
    authconfig --enableshadow --enablemd5
    selinux --disabled
    timezone Australia/Melbourne
    bootloader --location=mbr --driveorder=sda,sdb
    # The following is the partition information you requested
    # Note that any partitions you deleted are not expressed
    # here so unless you clear all partitions first, this is
    # not guaranteed to work
    clearpart --all --drives=sda,sdb
    part /boot --fstype ext3 --size=100 --ondisk=sda
    part pv.7 --size=0 --grow --ondisk=sda
    part pv.8 --size=0 --grow --ondisk=sdb
    volgroup VolGroup00 --pesize=32768 pv.7 pv.8
    logvol / --fstype ext3 --name=LogVol00 --vgname=VolGroup00 --size=1024 --grow
    logvol swap --fstype swap --name=LogVol01 --vgname=VolGroup00 --size=896 --grow --maxsize=1792


  18. falko

    falko Super Moderator ISPConfig Developer

    No, sorry. I'm a Debian guy...
    Where's that file located on your server?
  19. n1kol1s

    n1kol1s New Member

    in the root directory called anaconda-ks.cfg .
    And if i remember corecly when you boot from the fc cd you type linux ks=the path of the ks file e.g. floppy cd web usb key.
  20. incgnito

    incgnito New Member

    My two cent's worth...

    I don't know if this will help, but I was having the same issue until I saw falko talking about /etc/passwd and /etc/group; when I looked there myself I noticed that for whatever reason I had no anonftp users in /etc/passwd, and in /etc/group all I had was this:

    I changed the above line to:

    and added the following to /etc/passwd:

    web1_anonftp:x:12001:10001:JFI Anonymous User:/var/www/web1/ftp:/bin/false
    One thing to note: I added the line to /etc/passwd first, tried it, and failed before I checked /etc/group (I'm bull-headed like that sometimes), and though I saw falko make references to /etc/group there was no response from n1kol1s to that effect, so I would say definitely check /etc/group!

    Sorry if I'm out of line for sticking my nose in. I now return you to your average life... :p

Share This Page