Can't access control panel through Firefox

Discussion in 'Installation/Configuration' started by benbalbo, Oct 28, 2005.

  1. benbalbo

    benbalbo New Member

    When I log in to the control panel in Firefox, it hangs shortly after logging in. Sometime as soon as I log in, sometimes I can get as far as adding a new client, and then it hangs, to the extent that I have to force quit the application.

    I reinstalled ISPConfig to see if that helped, to no avail.

    I then tried accessing it through IE (running Crossover Office) and it works fine. Anyone else have this problem?

    There are no entries added to /home/admispconfig/ispconfig/ispconfig.log when up to the point Firefox hangs.

    I also don't have the startup script /etc/init.d/ispconfig_server - I'm guessing ISPConfig should have created this.

    Running Ubuntu 5.1, Apache 2, PHP 5.1 (from, MySQL4.1 - all other apps are as per the perfect install guide for Ubuntu 5.04.

    Thanks in advance,
  2. benbalbo

    benbalbo New Member

    I just tried using Mozilla 1.7.12, and it seems to work fine in this browser.

    If it helps, here are the full browser user_agent values:

    Mozilla 1.7.12: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.12) Gecko/20051013 Debian/1.7.12-1ubuntu1

    Firefox 1.0.7: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.12) Gecko/20051010 Firefox/1.0.7 (Ubuntu package 1.0.7)

    Internet Explorer 6.0.2800.1106: Mozilla/4.0 (compatible; MSIE 6.0; Windows 98)
  3. falko

    falko Super Moderator Howtoforge Staff

  4. benbalbo

    benbalbo New Member

    To the letter :)

    As I say - the system works in Mozilla and IE, just not in Firefox. Tis very strange.
  5. benbalbo

    benbalbo New Member

    Oops - just noticed you had 5.10 in the URL - that one wasn't there (or linked to from the ISPConfig docs page at least) when I looked.

    I'll take a look and see what the differences are.

  6. benbalbo

    benbalbo New Member

    Well I looked at the differences (very few) and reinstalled - still no Firefox support. There are still no errors in the log files. I'm guessing this is a firefox bug, although how that could be, I don't know...

    Thanks for the help though
  7. benbalbo

    benbalbo New Member

    Here's an interesting developement. My previous posts are for a ubuntu5.1 install. I've now also installed ISPConfig on a VPS running Debian testing, and firefox works fine with that. I'll double check when I get to work tomorrow to see if it's just firefox on my work machine that has a problem.
  8. till

    till Super Moderator Staff Member ISPConfig Developer

    I'am doing all my development on the ISPConfig interface with firefox and never had any problems.
  9. timehost

    timehost New Member

    Browser incompatibility

    Yes we are having the same problem. On Internet explorer 6 ISPCOnfig works fine. On my Linux workstation with Mozilla 1.7.12, I have to refresh manually very often (while changing from ISP Management to DNS Management for example) and hav to logout and login if I add a new site or new user to be able to see it on the tree menu.
  10. till

    till Super Moderator Staff Member ISPConfig Developer

    Please check your security settings in Firefox. Javascript and all kinds of header and http redirects must be enabled for ISPConfig.
  11. keesje76

    keesje76 New Member

    Same problem

    Although it's a pretty old thread, I seem to have the same problem, firefox only (

    It's due to extentions in my case. Starting Firefox in safemode 'solves' the problem.

    I have:
    IE lite
    html validator
    google pagerank

    If I've time I try to figure out wich one causes trouble.

    ISP config is not the only app triggering this problem.


    Open Source Webdevelopment
  12. Leszek

    Leszek Member

    I'd clear everything that is not needed at the moment (cookies,temporary files,saved certificates etc.) and try on a clean browser just to make sure.
  13. z33k3r

    z33k3r New Member

    I just wanted to add to this that, I have installed around five installations of ISPConfig all based off of the Perfect Ubuntu setup; all the way back to 5.05 and now up to 8.04. I have never had the issue to which FireFox hangs during use of the backend administrative panel.

    I just built a new server using Ubuntu 8.04 with ISPConfig 2.2.24 and it was working smoothly with FireFox 2 and FireFox 3 while in my office. Once I moved the server and installed it into it's new Co-located home (thus changing IP addressing), ISPConfig now hangs during the loading of the left side panel where the directory tree is. You can press the Stop button in your browers and it will show up, but if you don't, it will just sit there waiting for your server to load some kind of magical content.

    Internet Exploder works fine, but I would rather not have to dig up that shortcut from the depths of hell just to use a control panel...!

    Any ideas anybody?
  14. till

    till Super Moderator Staff Member ISPConfig Developer

    Please have a look in the file /home/admispconfig/ispconfig/lib/ and check that all IP's / URL's in this fike are correct for the current location of the server.
  15. z33k3r

    z33k3r New Member

    I have already checked there. There are no references to any IPs in that file...
  16. falko

    falko Super Moderator Howtoforge Staff

    Also check /root/ispconfig/httpd/conf/httpd.conf.
  17. z33k3r

    z33k3r New Member

    Already have checked there as well...
  18. falko

    falko Super Moderator Howtoforge Staff

    Can you try to clear your browser's cache?
  19. z33k3r

    z33k3r New Member

    Trust me, I already have. I have tried three different computers each with FF not working and IE working. I have 10+ years in computer support and I have tried every trick in my book. Like I said, there was nothing wrong untill the IP change... then FF stopped working and it's ONLY the left side bar where the tree view is held. Everything else loads fine. Is there some kind of hardcoded JS utilizing the IP?
  20. falko

    falko Super Moderator Howtoforge Staff

    We will release 2.2.25 in a few days. I've changed the Javascript code for the left frame (the tree) in it because some users had problem with their browsers loading that frame again and again. You might want to try to update to that release then.

Share This Page