cant connect to ispconfig

Discussion in 'Installation/Configuration' started by kingkunt, Dec 13, 2005.

  1. kingkunt

    kingkunt New Member

    Im using suse9.3 perfect setup and just finished a clean install of the server and ispconfig,everything seems to be fine with the install and setup.
    When i try to connect to htts:// i get connection refused?

    I checked the ispconfig file and the path is correct,ispconfig is running, and i get 403 error if i try the url without https://

    Any idea why id be unable to connect to ispconfig?
  2. falko

    falko Super Moderator Howtoforge Staff

    You have to use the same URL that's in /home/admispconfig/ispconfig/lib/ and that you entered during installation. Of course, the DNS records for this URL have to point to your ISPConfig system.

    Can you connect when you use the IP address instead?

    Did you disable SuSE's firewall, as suggested in the "Perfect Setup"?
  3. till

    till Super Moderator Staff Member ISPConfig Developer

    ISPConfig supports either http or https, never both. Have selected http or https during install?
  4. kingkunt

    kingkunt New Member

    I did a fresh install of suse9.3 perfect setup and installed ispconfig everything seems to work ok.
    When i first tried to connect to the adminCP i got a blank page(IE) when i tried with firefox it showed me the error invalid certificate,so i fixed that by rebuilding my cert and restarting ispconfig.
    My path in ispconfig is
    When i try to connect to it via this url i get a page cannot be displayed error.
    When i connect to it via it prompts me to accept cert and i can login,BUT when im logged in i see broken images and if i try to change some settings it asks if i want to display secure and non secure pages selecting eeither shows a blank page???

    i reinstalled because i had this problem last time so at this point im stumped.

    I selected https:

    I cannot connect using the WAN ip but i can connect using the router ip 192.168.x.x
    Firewall is off

    :confused: aaahrghh i want to fix this so i can try the new 2.1.2!!:eek:
  5. falko

    falko Super Moderator Howtoforge Staff

    When you try to connect to ISPconfig, you must use the same URL that is in /home/admispconfig/ispconfig/lib/, and you have to make sure the the DNS records for this URL are pointing to your ISPConfig server (unless you have an IP address in the file instead of a FQDN).

    You must forward port 81 from your router to your ISPConfig server.
  6. kingkunt

    kingkunt New Member

    well it seems my problem was the url in my ispconfig wouldnt let me connect using
    so i changed the url to removing the hostname from the url and it now works 100%
    it seems the ISPconfig setup idnt like my hostname added to the url.
    thanks for your patience.

Share This Page