Cant connect to mysql server from outside

Discussion in 'Installation/Configuration' started by EL7oot, Mar 20, 2006.

  1. EL7oot

    EL7oot New Member

    Hi everyone,
    i turned on the option mysql db accessible from outside, but it is not reachable. current system ist Fedora Core 4 with mysql 4.1 what am i doing wrong?

    i'm using "NAVICAT" program
    user: web2_u1

    cant connect to mysql on 82.129.14*.23* '10060'

    this is my configuration

    "netstat -tap"

    Proto Recv-Q Send-Q Local Address Foreign Address State PID/Program name
    tcp 0 0 *:imaps *:* LISTEN 1831/xinetd
    tcp 0 0 *:32769 *:* LISTEN 1439/rpc.statd
    tcp 0 0 *:pop3s *:* LISTEN 1831/xinetd
    tcp 0 0 *:mysql *:* LISTEN 13672/mysqld
    tcp 0 0 *:pop3 *:* LISTEN 1831/xinetd
    tcp 0 0 *:imap *:* LISTEN 1831/xinetd
    tcp 0 0 *:sunrpc *:* LISTEN 1421/portmap
    tcp 0 0 *:10000 *:* LISTEN 2515/perl
    tcp 0 0 *:81 *:* LISTEN 2237/ispconfig_http
    tcp 0 0 82.129.14*.23*:domain *:* LISTEN 1518/named
    tcp 0 0 *:* LISTEN 1518/named
    tcp 0 0 82.129.14*.25*:domain *:* LISTEN 1518/named
    tcp 0 0 server1.******.com:domain *:* LISTEN 1518/named
    tcp 0 0 *:ftp *:* LISTEN 30747/proftpd: (acc
    tcp 0 0 server1.*****.com:ipp *:* LISTEN 29460/cupsd
    tcp 0 0 server1.*****.com:5335 *:* LISTEN 1739/mDNSResponder
    tcp 0 0 server1.*****.com:rndc *:* LISTEN 1518/named
    tcp 0 0 *:smtp *:* LISTEN 373/master
    tcp 0 0 *:http *:* LISTEN 2381/httpd
    tcp 0 0 *:ssh *:* LISTEN 1822/sshd
    tcp 0 0 ::1:rndc *:* LISTEN 1518/named
    tcp 0 0 *:https *:* LISTEN 2381/httpd
    tcp 0 148 ::ffff:82.129.14*.25*:ssh ::ffff:82.129.14*.24*:3631 ESTABLISHED 26342/1
    tcp 0 0 ::ffff: TIME_WAIT -
    # Default to using old password format for compatibility with mysql 3.x
    # clients (those using the mysqlclient10 compatibility package).


    Note: i'm very new to linux

    i'm using Fedora Core 4 with tow real ip's
    Last edited: Mar 20, 2006
  2. falko

    falko Super Moderator Howtoforge Staff

    Is maybe your firewall blocking requests to port 3306 (MySQL)?
  3. EL7oot

    EL7oot New Member

    firstly thank you for interesting ....

    but no i have already created rule to accept the port 3306 and this is my firewall rules from ispconfig managment section

    FTP 21 tcp yes
    SSH 22 tcp yes
    SMTP 25 tcp yes
    DNS 53 tcp yes
    DNS 53 udp yes
    WWW 80 tcp yes
    ISPConfig 81 tcp yes
    POP3 110 tcp yes
    SSL (www) 443 tcp yes
    Webmin 10000 tcp yes
    Mysqld 3306 tcp yes

    NOTE: i have tried to log in with root account,
    the program returned with this error
    "1045 - access denied for user '[email protected]*.24*' (using password:Yes )"

    *this ip is for the client machine

    have you any idea aboute this problem?

    sorry aboute my bad english..,
    Last edited: Mar 21, 2006
  4. till

    till Super Moderator Staff Member ISPConfig Developer

    If you want to access a database from outside which you created in ISPConfig, you must use the username and password you set in ISPConfig for this database, not the root user.

    If you want to connect with root from outside, you will have to change the permissions for the root user in the mysql user database table and reload mysql.
  5. madlew

    madlew New Member

    I to get the same problem when trying to use mySQL-Front even on my internal networ.
  6. brainz

    brainz Member

    Only a suggestion but if your in a NAT enviroment...

    Usually wouldnt you need to either port forward port 3306 to the servers internal ip address and (im thinking rather then connecting to [email protected]*.24* the connection should be to something like this root@localhost or [email protected].*.*) in your router and also if the router has a firewall to allow for external connections to port 3306

    brainz :cool::rolleyes:
    Last edited: Mar 21, 2006
  7. EL7oot

    EL7oot New Member

    thanx braniz for ur suggestion but i'm using real ip address and i'm already connected with other db's on another servers on same port .

    thanx every body for helping me

    i have solved the problem ...

    and i don't know how:eek: :confused:

Share This Page