Can't See All Memory - CentOS 4.2

Discussion in 'Kernel Questions' started by technick, May 22, 2006.

  1. technick

    technick New Member

    I am in the process of setting up some servers, IBM X360 rack servers. They are decked out with 16 gigs of memory and quad xeon processors per system. CentOS is only seeing 8 gigs of the 16. I checked the BIOS, and the BIOS is reporting 16 gigs of ECC Registered memory correctly.

    I did some research and saw IBM recommending I use the EL Hugemem kernel, so I went out and tried that. Still the same results. Here's the current kernel information.

    [root@vs1 ~]# uname -a
    Linux 2.6.9-34.ELhugemem #1 SMP Wed Mar 8 00:47:12 CST 2006 i686 i686 i386 GNU/Linux
    [root@vs1 ~]# free
                 total       used       free     shared    buffers     cached
    Mem:       8032148    8012260      19888          0       9956    7730756
    -/+ buffers/cache:     271548    7760600
    Swap:     16386292          8   16386284
    [root@vs1 ~]#
    I was trying to advoid rebuilding the kernel, but I have a feeling I might have too.

    Any advice / suggestions would be greatly appreciated.

    Thanks in advance.

  2. technick

    technick New Member


    I went ahead and compiled a new kernel based off of the current config with a few changes and still the same issue. I compiled 2.6.17 with the same results. I verified that largemem was available and it was set for 64 gigs of memory.

    I need help guys......

    I'll be patiently waiting...
  3. falko

    falko Super Moderator ISPConfig Developer

Share This Page