clamav-daemon stopped working with update to version 0.99

Discussion in 'General' started by kerrsmith, Jun 5, 2016.

  1. kerrsmith

    kerrsmith Member

    I am running Debian GNU/Linux 8 (jessie) and today clamav-daemon updated to the latest version 0.99+dfsg-0+deb8u2.
    Unfortunately it appears to have now stopped working.

    I ran clamd -V and get the following:
    ERROR: Parse error at line 11: Unknown option AllowSupplementaryGroups
    ERROR: Can't open/parse the config file /etc/clamav/clamd.conf

    I did a Google search and found the following information:

    Apparently the option AllowSupplementaryGroups has been removed and this is stopping clamav-daemon from starting up.

    I assume this option is needed as it is specifically set in 'The Perfect Server Set Up'.

    Does anyone know if this can be disabled (commented out) or if there is a workaround?
  2. Jesse Norell

    Jesse Norell Well-Known Member Staff Member Howtoforge Staff

    The bug report you posted sounds like there will be another package update to address that soon; just comment out that line for now.
  3. kerrsmith

    kerrsmith Member

    Thanks for the reply - I actually just tried that a couple of hours ago just to see what happened. It started up and did not mention any issues in the logs. I was waiting for the hourly updates to happen and it appears to be working as normal.

    Email is being received and sent as usual now - I have just been testing it the last few minutes.
  4. DDArt

    DDArt Member

    Had the same issue, with the update. I also kept the same .conf file, and not install the new packaged file when prompted.
    Doing this caused identical problem.

    Commenting out the clamd.conf line with "AllowSupplementaryGroups true" and restarting service worked.

Share This Page