Clean installation Perfect server Debian 8.6 nginx - PROBLEMS

Discussion in 'Installation/Configuration' started by Petar, Aug 1, 2017.

  1. Petar

    Petar Member HowtoForge Supporter

    I followed this tutorial:
    No changes made (i'm fairly experienced user >100 installs of the same tutorial on different configurations).
    - - - -
    First default mistake: If i go into
    ISPc Menu > Monitor > RKhunter log
    i get this error:
    Invalid WEB_CMD configuration option: Relative pathname: "/bin/false"
    - - - -
    Second error:
    At first webmail login screen was working and it was accessible at ip-address:8081/webmail(squirrelmail).
    then after just checking some settings(just clicking at the tabs - not changeing anything) either in the
    System > Server Config
    Email > Email inbox,
    i cannot login to the webmail, because on the main screen of webmail i get :

    CONFIGURATION ERROR was not found.
    Please read the INSTALL instructions!

    Can you please change the Tutorial and post the necessary changes here?
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    Both issues are not a problem of the tutorial.

    The rkhunter one seems to be a bug in the rkhunter Debian package. Here is a workaround until Debian fixes it (it's in german, but you ight be able to read it with google translate):

    The issue with SquirrelMail has been reported already, it is most likely a problem in ISPConfig itself, but we were not able to find the reason for it yet as it just seem to happen sometimes on some systems. We'll look into that.
  3. Petar

    Petar Member HowtoForge Supporter

    Thanks for the support Till.
    I will install it several times in different VMs and try to pin point the problem menu. One of the mentioned menu in System > Server Config autosaves something which should already be default and makes the problem. I will test step by step to find it out.
    It is easily noticeable, because the large red circle label with number of 2-3 changes appears in the header, without any prior action taken from the user...
    will let you know soon...
  4. till

    till Super Moderator Staff Member ISPConfig Developer

    What you should do is that you check the file content and ownership of the squirrelmail config file on a freshly installed system and compare it after you used the server settings.
  5. Petar

    Petar Member HowtoForge Supporter

    Hi Till
    About the Debian+Nginx+Roundcube problem = was not found
    I've been investigating the code of ISP Config and couldn't find the reason for the problem there.
    As i found on lot of the chat on forums the main reason is that, debian-db.php and some other files are owned by root:www-data. If i only change to chown root:ispapps everything will work immediately.
    Here is a complete list of files with changed ownership and permissions proposed:

    chown root:ispapps /etc/roundcube/debian-db.php
    chmod 640 /etc/roundcube/debian-db.php
    chown root:ispapps /etc/roundcube/
    chmod 640 /etc/roundcube/
    chown -R ispapps:adm /var/log/roundcube
    chmod -R 750 /var/log/roundcube
    chown -R ispapps:ispapps /var/lib/roundcube/temp
    chmod -R 750 /var/lib/roundcube/temp

    I hope it will help you to find the part in ISPconfig where this changing of ownership should have been done.
    JettB, termik, zakjakub and 5 others like this.
  6. emcee

    emcee New Member

    Thank you for this. It made my day :)
    Petar likes this.
  7. Chowder

    Chowder New Member

  8. helios842000

    helios842000 New Member

    work fine on ubuntu 16.04, thx for this fix

Share This Page