Compile Kernel 2.6 under Debian Sarge

Discussion in 'Kernel Questions' started by falko, Apr 21, 2005.

  1. dansaycool

    dansaycool New Member

    New problems lol

    Hi, i have followed this guide (which was supurb btw thankyu so much:) ) and have succesfully installed kernel- on my debian system. But now am wondering how one goes about instaling the kernel headers for it.
    My problems all start when i bought a Netgear WG311 Wireless PCI Card, im following a guide for it i found

    Found out in the sys requriments page you need at least a kernel of 2.6.10 which i had 2.6.8,

    so i followed this guide and installed the latest kernel at the time. But it also says it needs the kernel header files installed which i cant find out how to compile or install. Ive tried installing the module-assistant and using the "prepare" feature which should install the correct kernel headers, but its unable to find any for the kenerl.
    Does anyone know what to do or where to go on from here lol
    Many thanks dan :)
  2. falko

    falko Super Moderator Howtoforge Staff

    If you compiled your kernel from the sources, then all header files are already on the system. If you installed a Debian kernel image, then you need to install the appropriate kernel-header package with apt-get. You can search for the appropriate package with
    apt-cache search kernel
  3. dansaycool

    dansaycool New Member

    ahh thanks, so because i followed this guide i don't need to install the header files lol thanks again for all your help
    ta dan
  4. falko

    falko Super Moderator Howtoforge Staff

    Yes, right.
  5. tom

    tom Member

    I'm not able to install a new xen kernel on debian sarge.
    This maschine I have:
    I've downloaded with apt this files and xen xen-tools etc.

    With this xen-kerneln I've tried to boot:
    linux-image-2.6.17-2-xen-k7 - Linux 2.6.17 image on AMD K7
    linux-image-2.6.16-2-xen-k7 - Linux kernel 2.6.16 image on AMD K7 machines
    linux-image-2.6.16-1-xen-k7 - Linux kernel 2.6.16 image on AMD K7 machines


    After the grub bootpromt grub is boot in xen but nearly 10 secounds later the bootpromt is arising again. Now I can see nothing after the bootpromt because it's no console there while booting dom0. I don't know why the bootprozess is interrupted and I cant see any hints because it is nothing to see.

    What should I do?
    Last edited: Oct 15, 2006
  6. falko

    falko Super Moderator Howtoforge Staff

    I've had this problem once myself. All I could do was to compile another kernel.
    What's the output of
    uname -m
  7. tom

    tom Member

    I thoght [B]i686[/B] is standing for intel prozessors???
    What have you changed in your kernel?
    Do you still have your config file?
    I've use this: to compile an new kernel. But make oldconfig and make menuconfig does'nt work:

    Do you have a hint to get the seriell console showing something during the boot prozess?

    Even I'm using software raid (raid1). Do you thing it could depence on it. Maybe xen does'nt support software raid.

    Another prob while installing the linux-image-2.6.17-2-xen-k7 arrised. An script configured grubs menue.list during the installations prozess. After rebooting grub could'nt boot anything and even was'nt able to show the bootmenu.

    Now I can't boot anyting even not the usual kernel. The only way to boot is booting external. Grub is installed on both raid devices and both raid devices are working well. I've no idea how I can fix that.
    Last edited: Oct 16, 2006
  8. falko

    falko Super Moderator Howtoforge Staff

  9. miro

    miro New Member

    Help me :confused: :mad: Please ?!

    im doing every this like you say and still im getting this error

    Debian:/usr/src/linux- cd ../
    Debian:/usr/src# dpkg -i kernel-image-
    dpkg: error processing kernel-image- (--install):
    cannot access archive: No such file or directory
    Errors were encountered while processing:
  10. falko

    falko Super Moderator Howtoforge Staff

    What's the output of
    ls -l /usr/src
  11. jineesh

    jineesh New Member

    kernel config problem (same error already reported by #76)

    i tried to compile kernel 2.6.18. All working fine upto the command
    fakeroot make-kpkg --revision=custom.1.0 kernel_image
    after one hour process it shows an error and quits. the error is as follows.

    COLUMNS=150 dpkg -l 'gcc*' perl dpkg 'libc6*' binutils ldso make dpkg-dev |\
    awk '$1 ~ /[hi]i/ { printf("%s-%s\n", $2, $3) }' > debian/buildinfo
    awk: relocation error: awk: symbol _dl_catch_error, version GLIBC_PRIVATE not de fined in file with link time reference
    make: *** [debian/stamp-build-kernel] Error 127

    thanks jineesh
  12. falko

    falko Super Moderator Howtoforge Staff

    I think you need to install glibc-devel.
  13. jineesh

    jineesh New Member

    Thank you for your response.
    But i dont know how to install glibc-devel. i m new to linux.
    Plz help me.
  14. falko

    falko Super Moderator Howtoforge Staff

    Which distribution do you use? If it's Debian, you can search for the appropriate package like this:
    apt-cache search glibc
    Once you have found the right packahe you can install it:
    apt-get install [I]package[/I]
  15. jineesh

    jineesh New Member

    sorry to inform you that still it shows the same error. I installed glibc pakages as you said. :confused: :confused: :confused:
  16. falko

    falko Super Moderator Howtoforge Staff

    You can try this:
    apt-get install build-essential
  17. tino097

    tino097 New Member


    im quite new to Linux, and i followed instructions, but i use config file given in the first post and change nothing there cause im not sure what need to do.

    during the re-compiling of kernel i didnt get error messages, but after rebooting i recived this mesage during booting :

    so if someone can give me instructions what to do and where to change this settings

  18. tino097

    tino097 New Member

    i solve the problem above but now my USB mosue wont work

    any ideas where to look ?
  19. falko

    falko Super Moderator Howtoforge Staff

  20. ikkem

    ikkem Member

    I have a question....
    I was trying to compile kernel source on debian etch but iptables module does not seem to load or iptables has to be compiled againts the kernel source (I guess) but I could not find any info on google or clusty...
    Has much changed regarding the compilation with the release of

    thanks in advance....

Share This Page