"Connect : Network is Unreachable"

Discussion in 'Installation/Configuration' started by Sinisfun, Jan 16, 2006.

Thread Status:
Not open for further replies.
  1. Sinisfun

    Sinisfun New Member

    This started this morning, I woke up and my site was there, checked my mail, and then my site was gone. When I login locally and try and ping google.ca I get "Connect : Network is unreachable" ifconfig eth0 shows the ip address has changed to a .101 from a .103 so I change it back, however the site cannot be seen and I cannot connect to it using putty.... I am at a loss, I have googled and searched and I can find many others with this issue, however very few if any solutions. Any help would be welcomed...

  2. till

    till Super Moderator Staff Member ISPConfig Developer

    Have you checked your router?

    What is the output of:

    netstat -nr
  3. Sinisfun

    Sinisfun New Member

    dest Gateway Genmask Flags MSS Window irtt iface u 0 0 0 eth0
  4. till

    till Super Moderator Staff Member ISPConfig Developer

    please try this:

    /sbin/route add -net gw eth0

    where you have to replace with the internal IP address of your router (gateway).
  5. Sinisfun

    Sinisfun New Member

    Absolutely Stunning... It works Thank you for the great reply times and accuracy. May I ask what may have caused this so I can possibly prevent future issues?

    Again thanks so much.... you rock!

  6. till

    till Super Moderator Staff Member ISPConfig Developer

    Something has deleted the route to the gateway on your server. Can you check with the "uptime" command if your server rebootet at the time the problems begun?
  7. Sinisfun

    Sinisfun New Member

    It says that it has been up for 14 days...
  8. falko

    falko Super Moderator Howtoforge Staff

    Maybe a server oops... ;)

    To be on the safe side I'd run chkrootkit and Rootkithunter to check if your system has been hijacked. You can never know...
  9. Sinisfun

    Sinisfun New Member

    I get this as output from chkrootkit
    Checking `rexedcs'... not found
    Checking `sniffer'... eth0: not promisc and no PF_PACKET sockets
    Checking `w55808'... not infected
    Checking `wted'... chkwtmp: nothing deleted
    Checking `scalper'... not infected
    Checking `slapper'... not infected
    Checking `z2'... chklastlog: nothing deleted
    Checking `chkutmp'...  The tty of the following user process(es) were not found
     in /var/run/utmp !
    ! RUID          PID TTY    CMD
    ! root         7684 tty6   /sbin/getty 38400 tty6
    chkutmp: nothing deleted
    There is more to the list however everything else states that there was nothing found, this however list eth0 and I dont know what it is telling me.
    Rootkit Hunter Finds this
    System checks
    * Allround tests
       Checking hostname... Found. Hostname is mikethetv
       Checking for passwordless user accounts... OK
       Checking for differences in user accounts...                       [ NA ]
       Checking for differences in user groups... Creating file It seems this is your first time.
       Checking boot.local/rc.local file...
         - /etc/rc.local                                          [ Not found ]
         - /etc/rc.d/rc.local                                     [ Not found ]
         - /usr/local/etc/rc.local                                [ Not found ]
         - /usr/local/etc/rc.d/rc.local                           [ Not found ]
         - /etc/conf.d/local.start                                [ Not found ]
         - /etc/init.d/boot.local                                 [ Not found ]
       Checking rc.d files...                                     [ Not found ]
       Checking history files
         Bourne Shell                                             [ Not Found ]
    * Filesystem checks
       Checking /dev for suspicious files...                      [ OK ]
       Scanning for hidden files...                               [ Warning! ]
    /dev/.initramfs-tools /etc/.pwd.lock
    Please inspect:  /dev/.static (directory)  /dev/.udevdb (directory)
    I noticed that it created a user file... do you think this will interfere with ISPconfig?

    Any ideas or does everything look ok?
    Last edited: Jan 16, 2006
  10. till

    till Super Moderator Staff Member ISPConfig Developer

    I think this is normal, as far as i know these directories where created when you install raid.

    Chkrootkit and rkhunter work fine together with ISPConfig.

    I think its ok.
  11. Sinisfun

    Sinisfun New Member

    Great thanks again for all of your help!!
  12. fedix

    fedix New Member

    Network Unreachable

    I can't connect to the internet. If I try to ping the default gateway or proxy server, I get a "network unreachable" error.

    Similarly, if I try to open Firefox to browse the internet, I get the "proxy server is refusing connections" page. And "Add/Remove Software" returns "Unable to retrieve software information".

    It did work directly after installation, but I changed to static IP, played with a few settings and then back to DHCP. Now this unreachable error.

    I'm using Fedora 5

    My settings are:
    DHCP enabled
    IP: xxx.xxx.179.254
    DEFAULT GATEWAY xxx.xxx.176.8
    DNS: 1 xxx.xxx.178.75
    DNS: 2 xxx.xxx.178.74
    DNS: 3 (internet)

    Connection settings in Firefox
    proxy : xxx.xxx.176.108:3128

    Any help to solve this?

    Thanks !!!:)
  13. falko

    falko Super Moderator Howtoforge Staff

    What's the output of
    ? Did you try to reboot your system?
  14. fedix

    fedix New Member


    Reboot? Yes, no resolution.

    ifconfig? I get the following output? bash: ifconfig: command not found. I'm using Fedora 5 default install? If not ifconfig, how do I ipconfig my system?
  15. till

    till Super Moderator Staff Member ISPConfig Developer

    The command ifconfig is correct. You must execute it as root user.
  16. falko

    falko Super Moderator Howtoforge Staff

    You must run that command as root, as Till said. If you still get the error message, please post the output of
    echo $PATH
  17. maui

    maui New Member

    Question for Till

    Till I am having the same problem as the other dude described; but when I try to run the command /sbin/route add gw eth0 ( being the ip of my router) I get the following error:

    SIOCADDRT: Network is unreachable: mad::confused:

    Any suggestions?? thanks for the help
  18. till

    till Super Moderator Staff Member ISPConfig Developer

    Please post the output of:

  19. shadowen2

    shadowen2 New Member

    One more tidbit

    After all these years, I finally have something to add.

    I've been having this problem on a brand new Intrepid server I just installed. This thread helped me realize the error of my ways. I rechecked the file in /etc/network/interfaces and discovered I'd made an error where I'd specified a static IP address. I had given it the incorrect IP address of my router. So if anyone else out there finds this thread, with this problem, be sure to recheck your IP addresses. One digit obviously means a lot.
  20. Polk

    Polk New Member


    After I ran this:

    /sbin/route add -net gw eth0

    if fixed my problem, but when i restart the network by:

    /etc/init.d/network restart

    it removes the route again and I loose connection. How do I save that route permanently? so even after restarts it was there?

Thread Status:
Not open for further replies.

Share This Page