Couldn't Stat source package

Discussion in 'HOWTO-Related Questions' started by linds, Mar 7, 2006.

  1. linds

    linds New Member

    I am trying to download with apt-get update on my ubuntu server and i am getting an error message W: Couldn't stat source package

    Then it lists an http: location.

    It also mentions something (2 No such file or directory)

    I ran into this before, but I don't know what I did to resolve it? I remember I tried rebooting logging in as a different user

    Am I not getting out to the internet or what could be stopping these updates?
  2. linds

    linds New Member


    Well I reinstalled the whole thing and went through the steps on How to set up samba on ubuntu and this time I get very similiar error messages. But on the first package it tried to find and I could see the percentage slowing increasing until 50% and then it stopped and I got a bunch of error messages that said Temporary failure resolving

    I am going to attach a picture of my screen in case seeing the rest of the error messages helps someone see and solve my problem


    Maybe this update is not possilbe because Ubuntu download location is down???? Just guessing.
    Last edited: Mar 7, 2006
  3. till

    till Super Moderator Staff Member ISPConfig Developer

    The errors mean that you have a problem with your internet connection. If you get an error about resolving a domain, you will have to check that the nameservers in /etc/resolv.conf are working and reachable from your server.
  4. linds

    linds New Member

    I checked the name server but how do I check if they are reachable?

    I pinged the address It gave me . then I pinged it on my windows machine. I got a reply no problem? Is there a way I can test my internet connection on Linux?
    Last edited: Mar 7, 2006
  5. linds

    linds New Member

    It says it is a temporary failure resolving

    What would it mean by temporary?
  6. till

    till Super Moderator Staff Member ISPConfig Developer

    The error message is always temporary, even if its a permanent failure. I suggest to try another nameserver in /etc/resolv.conf. Did you get more nameserver IP addresses from your provider that you cann add in the resolv.conf?
  7. falko

    falko Super Moderator Howtoforge Staff

  8. linds

    linds New Member

    Actually I never got a nameserver IP address? at least not that I knew of, the one in there now got there automatically. So if I ask my isp for another nameserver ip address they'll now what I mean?
  9. linds

    linds New Member

    Falko, maybe you hit a problem, ping attempts google came back unknown and the number came back unreachable.

    Name server=

    It seems like I may not be connected. I have attempted several installs and the other times I was connected without even thinking about it. Might I have to do some manual configuration for my ethernet connection to be found? When installing ubuntu originally it asks a question about what I would like to use to connect between wireless and my ethernet. I don't have wireless here so I choose the ethernet. Than it always comes to a place where it tries to auto configure DCHP, it always comes back that it was unable what would I like to do, so I say retry and it comes back that it has successfully configured it.

    Funny this has worked before automatically but since then I have re installed.

    Not sure what I am doing wrong

    I tested my machine in another network port that was definatly getting out to the internet, Negative
    Last edited: Mar 8, 2006
  10. falko

    falko Super Moderator Howtoforge Staff

Share This Page