Create symlink for clientX/webY/web to /home/clientX/webY/web

Discussion in 'Installation/Configuration' started by KTee, Mar 5, 2017.

  1. KTee

    KTee New Member


    ISPConfig is installed but var/www is too small the main partition being home/

    In order to have all the files that weight in home/ I'm trying to understand how I can symlink only the :

    var/www/clients/clientX/webY/web directory to the home/clientX/webY/web folder

    As I have read that it's preferable to keep the "whole site" under var/www if suExec is needed, I though I could only move the web directory

    Is that possible ? Is it available through the ISPConfig panel ?

    Or do I have to create it manually ?

    Or is there any other way to move whole sites to home/folder without loosing suExec ?

    Best regards

  2. till

    till Super Moderator Staff Member ISPConfig Developer

  3. KTee

    KTee New Member

    Hi Till,
    Many thanks for your answer, I'll try that very soon. It seems to be the perfect answer to my problem ;)

    Thanks again,

  4. Fannydoll

    Fannydoll New Member


    I made the command to switch to /home/ that you specify, it's works, but I now ask myself these questions:

    - Can I run ISP Config updates after passing this command ?
    - Why is the / var / 1 partition space also filled in while the site is now added to / home /, is it because of logs?
    - Should the logs also be moved to / home /? If yes in the same way? Or with symbolic link?
    - How long are the logs kept ?
    Sorry for my bad English, I used a translation tool I hope it's not too incomprehensible ..

    Thank you for your help
  5. Fannydoll

    Fannydoll New Member

    Hello, little up... I need an answer please for update ISPCONFIG3 after this command...
    Thank you.
  6. iNet Specialists

    iNet Specialists New Member

    Yes. ISPConfig updates should work just fine. The instructions provided just use the power of the Linux filesystem to point /var/www to use the space available at /home/www
    Only because the original "/var" mount point also exists and points to a different volume. System logs will be stored in /var/log while client related logs will be in /home/www/clients/clientX/webY/log, so in effect, the client log storage has already been moved.
    The client logs are created from the vlogger application and split into the client logs.
    The client logs are typically kept for 30 days and have file names like YYYYMMDD-access.log.gz
    The original apache logs are in /var/log/httpd/, are kept according to the system settings in the /etc/httpd/conf/httpd.conf and /etc/logrotate.d/httpd files
  7. Fannydoll

    Fannydoll New Member

    Thank you very much !
  8. KTee

    KTee New Member

    Hi again,

    We made the changes in order to have /var/www into /home/www instead.

    But I have a bigger problem now and I don't seem to figure out why but since then, I can't have HTTP requests to respond while all HTTPS requests proceed corretly.

    Example :

    If I ask for : http :// domain.tld or http :// www. domain.tld => I'm given the ISP Config index welcome page :

    But in the mean time,
    If I ask for : https :// domain.tld or https :// www. domain.tld => I can see the website

    Note that if HTTPS is not activated for a website, HTTP requests will still provide the index welcome page from ISP Config

    What did I checked :

    - I checked that no index.html file is situated in the directory ( /var/www/clients/clientXX/webYY/web/ )
    - I tried deleting the symlink in sites-enabled to check if site was still responding and IT DID ! So it seems the vhost file is not involved...
    - Before all this, maybe is it good to know that each time I added a new site to ISP Config I faced problems of configuration with vhost that would not respond properly (HTTP version not configured properly)

    Note : I use let's encrypt to generate SSL certificates

    Hope you'll have time to look at this issue,

    Many thanks in advance,

  9. KTee

    KTee New Member

    Sorted !!!

    In fact problem was that one of the new sites was not configured properly and the IP input of this site was taking precedence over all the other sites (IPV6 not empty)

    (As mentioned by Till in this post : it's the * IP problem)

    Best regards,



Share This Page