Cron behind a secured directory

Discussion in 'Installation/Configuration' started by Wamcer, Mar 31, 2015.

  1. Wamcer

    Wamcer New Member

    Im only a user, i dont have access to server files besides the one i have in my ftp web.

    I sat up a couple of cronjobs. All point to a file that lies behind a protected directory. In order to make the cronjobs able to run i changed the paths and added User: Pass@

    Now at least i get an entry in the errorlog, which didnt happen before. It says: [Tue Mar 31 20:17:01.557893 2015] [auth_basic:error] [pid 5287] [client] AH01618: user Xelali not found: /MarginBot/crons/TenMinuteCron.php

    The path of the protected order is /MarginBot/ directly in the web-dir. And i sat it up with ISPConfig 3. When i want to go in through browser then i have to enter the userpass: Xexali and 2E3zGvR...SdVrWyXs (points are placeholder) and i can go in. Though that doesnt work for the cron job. The path for the cron is:

    so i use:

    http://Xelali:[email protected]/MarginBot/crons/TenMinuteCron.php

    But i only get the above errormessage in error log.

    What can i do to fix that?

    Last edited: Mar 31, 2015
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    Did you test the URL in a webbrowser? The error anove says that the htaccess login iw not working.
  3. Wamcer

    Wamcer New Member

    I sat up the secured directory n ispconfig 3 directly and i attached a user to it. When i want to go into the subdir through a browser then i add those users user and pass and i can get in. I then added those exact user and pass in the link above but for some reason it claims the user doesnt exist. Even though i can use the user and pass in a browser to get into that dir.

    Is that an error in ispconfig?
  4. till

    till Super Moderator Staff Member ISPConfig Developer

  5. Wamcer

    Wamcer New Member

    On the shell, sounds like i need server access. I guess i cant test this then since i only have this space from my former employer and i dont want to bother him too much with that free service.

    Guess i have to let it disabled for now in order to being able to run my script. I sat the robots.txt to block indexing of that directory so i think it might be safe enough.

    But thanks for the help. I thought it might be solveable without server access.

Share This Page