Debian 11 - error while installing on lxc (/ispconfig.ai.php:15)

Discussion in 'Installation/Configuration' started by DeviC3, Jan 18, 2022.

Tags:
  1. DeviC3

    DeviC3 New Member

    Hello I'm trying to install ISPConfig on Debian 11.
    Type of machine is lxc on Proxmox. I was trying to install using https://www.howtoforge.com/ispconfig-autoinstall-debian-ubuntu/
    Output log is:
    ```
    18.01.2022-14:10:59 - /ispconfig.ai.php:15: [ERROR] Exception occured: ISPConfigOSException -> Installing packages failed.
    ```

    I was trying with flags --no-quota and even --debug not showing any other output.
    php-cli is also set to 7.4
     
    Last edited: Jan 18, 2022
  2. Taleman

    Taleman Well-Known Member HowtoForge Supporter

    Install on Proxmox virtual machine instead of on lxc container. That should work better.
     
  3. DeviC3

    DeviC3 New Member

    Is there any future issues to not to use it on LXC ?
     
  4. till

    till Super Moderator Staff Member ISPConfig Developer

    LXC does not support Linux quota, so you won't be able to limit website sizes. And if I remember correctly, then you must run it in privileged mode. LXC is just a Linux container, not a VM. Therefore it's better to create a VM in Proxmox and not an LXC container.
     
  5. DeviC3

    DeviC3 New Member

    Thank You @till
    Is there any way to avoid this warning while installing ISP Config from script to get to end configuration ?
     
  6. Taleman

    Taleman Well-Known Member HowtoForge Supporter

    What warning?
     
  7. till

    till Super Moderator Staff Member ISPConfig Developer

    In your first post, you remove the lines from the output that show which packages failed, which is right before that line you posted. Post the full output so we can see what failed.

    And as mentioned before, you are using an unsuitable virtualization type and all you have to do to fix that is using a VM in proxmox instead of LXC.
     
  8. ahrasis

    ahrasis Well-Known Member

    In short, it is not easy to install ISPConfig server in an LXC due to certain limitation, thus if you don't know how to handle the errors in LXC (which can occur again, and again, and again... may be endlessly) you shouldn't be using it and instead should create and use VM on the PVE to install ISPConfig server. It is more stable and reliable running any ISPConfig server that way.
     
  9. DeviC3

    DeviC3 New Member

    Maybe there is bug in auto installer, output informing that is non-free packages is added to sources.list but it doesn't.
    After manual adding installation process runs further.
     
  10. Th0m

    Th0m ISPConfig Developer Staff Member ISPConfig Developer

    Can you share the content of the sources file before running the script?
     
  11. DeviC3

    DeviC3 New Member

    @Th0m
    You need /etc/apt/sources.list ? Content is:

    Code:
    deb http://ftp.debian.org/debian bullseye main contrib
    deb http://ftp.debian.org/debian bullseye-updates main contrib
    deb http://security.debian.org bullseye-security main contrib
    
     
  12. Th0m

    Th0m ISPConfig Developer Staff Member ISPConfig Developer

    That might be the problem. That it has contrib already.
    @Croydon wdyt?

    See https://regex101.com/r/FeNTNy/1 as well, this is the regex used in https://git.ispconfig.org/ispconfig...r/lib/os/class.ISPConfigDebianOS.inc.php#L323
     
  13. Croydon

    Croydon ISPConfig Developer ISPConfig Developer

  14. Croydon

    Croydon ISPConfig Developer ISPConfig Developer

  15. Th0m

    Th0m ISPConfig Developer Staff Member ISPConfig Developer

    DeviC3 and Croydon like this.

Share This Page