Debian Jessie: Self compiled PHP 7 and GDlib

Discussion in 'Installation/Configuration' started by Hbod, May 1, 2017.

  1. Hbod

    Hbod Member


    I followed the tutorials for compiling PHP 7 as FPM/FastCGI multiple times and it always worked flawlessly for me. But this time, when I compiled PHP 7.1.3, everything is working as intended but not the gdlib. All my REDAXO/ TYPO3 / Wordpress Installations aren't capable of generating thumbnails, regardless which size or setting I use. I don't even get any error messages, just memory timeouts, no matter what. Long story short: I can't do any image manipulation (jpg, png etc)

    When I switch back to 7.0.x, everything works again (also self-compiled). Did anyone else encounter this problem, too? Is there a way to fix this? I saw 7.1.4 is out, but I am not sure if this will fix my problem as the changelogs on do not include anything related to images. (I recompiled 7.1.3 two times, the issue still persists). The compilation worked without any error message.

    Thanks in advance!
    Last edited: May 1, 2017

Share This Page