Debian Sarge - phpMyAdmin has no import

Discussion in 'Installation/Configuration' started by Nap, Nov 11, 2006.

  1. Nap

    Nap Member

    I followed Falko's Perfect Sarge install, and installed the relevant packages. I have also installed ISPConfig. Everything is basically working.

    The current Debian phpMyAdmin (2.6.4-pl3) does not have an import function.
    I need to import data from my live website into the server I setup, and am not sure how to do it. I don't know anything about using the MySQL commandline, since I normally been doing it through my website's phpMyAdmin (and don't have shell access to my website anyway).

    Has anyone here that followed Falko's install guide upgraded their phpMyAdmin after completing his guide? (And the same for MySQL?) Does doing this have an impact on the ISPConfig?

  2. Hans

    Hans Moderator ISPConfig Developer

    Import a database with your phpmyadmin

    On the left site select the database of your web.
    For example: webx_db1
    (If you don't have a database for your web, create it first via ISPConfig).

    Press the SQL tab (the second tab).
    Browse to your sql.file and press the Start button to import it.

    When you're done, press the green exit button.
    That's all.
  3. Nap

    Nap Member


    Thnx 4 the reply.
    I did try that method b4 I posted here. After you mentioned it, I tried again but this time with a smaller file that only had one table in it. The original file I was using was only 2MB, well short of the 8mb stated.

    This time I got an error message saying 'DEFAULT CHARSET=latin1 AUTO_INCREMENT=14', which is part of the CREATE TABLE step. I looked again in the forums and found someone else who had a similar problem, and the explaination given was that it has to do with MySQL v4.0 vs v4.1.

    I've hunted high and low looking for more recent versions of PHP4, MySQL 4 packages for Debian, but no luck.

    I am contemplating installing Ubuntu on that machine instead.

  4. Hans

    Hans Moderator ISPConfig Developer

  5. Nap

    Nap Member



    First, I'm going to install Ubunto in place of Debian.

  6. Hans

    Hans Moderator ISPConfig Developer

    For a server i really recommend Debian...but it is your choice.
    Also on Debian you can run mysql 4.1 and up!
  7. Nap

    Nap Member

    Hi Hans,
    Thnx for the encouragement.

    Problem is that I can't seem to find the packages I need. I'm not experienced enough with Linux to 'go my own way' and download the applications' binaries from the developer's sites, let alone compile my own binaries.

    I have the backport site in my sources.list file (deb sarge-backports main contrib non-free) but the MySQL 4.1 (according to Synaptic) is an 'empty transitional package'.

    I would also like a more recent (but not latest) version of PHP4 and the latest phpMyAdmin.

    Ideally I would like:
    Apache 1.3.37,
    MySQL 4.1.21,
    phpMyAdmin, and
    Perl 5.8.7
    (Which are the versions my webhosting company uses. They are running Red Hat Enterprise Linux)

    You mentioned the phpMyAdmin pkg for ISPConfig. Am I correct in assuming that is only the plugin for ISPConfig, and that I need to get/install the phpMyAdmin from somewhere?

    Last edited: Nov 13, 2006
  8. Hans

    Hans Moderator ISPConfig Developer

    On Debian (stable), you can give the command:

    apt-get install mysql-server-4.1 mysql-client-4.1 libmysqlclient14-dev
    to install mysql 4.1.11

    If you like to have phpMyAdmin on your ISPConfig server, the only thing what you have to do is upload the .pkg from the ISPConfig website via the update manager within ISPConfig.

    No more no less.

    After installing the package, you can access phpmyadmin via URL http://anywebsiteonyourserver:81/phpmyadmin/

    Debian search for available aplications:

    apt-cache search aplicationname

    (where applicationname = for example mysql)

    You can install the apps of your choice with the apt-get command.
  9. Nap

    Nap Member

    I updated the phpMyAdmin, and the Import function worked, well almost.

    Previously, using the SQL tab, nothing happened. My browser status bar said waiting for my server, and after about 5 minutes, an empty file was returned as a download but nothing was added to the database.
    When I shortened the file to 1 table, it worked but that wasn't practical since this database has 120+ tables.

    Using the Import function in the updated phpMyAdmin, it worked much better. 124 tables imported but I got this error at the end of it:

    Warning: Cannot modify header information - headers already sent by (output started at /home/admispconfig/ispconfig/web/phpmyadmin/libraries/ in /home/admispconfig/ispconfig/web/phpmyadmin/libraries/common.lib.php on line 1154

    I haven't done any investigations to see why it happened, so I can't offer any advice about it atm.

    I'm going to check the database to see if everything went in.

  10. Nap

    Nap Member

    Hi Hans,

    I just added a new database/user through ISPConfig, and all of a sudden I get this error message in phpMyAdmin:

    phpMyAdmin - error

    #1251 - Client does not support authentication protocol requested by server; consider upgrading MySQL client

    Prior to doing this, I was able to use phpMyAdmin without problems.

    I used the apt-get install command you showed me. Everything went through ok. I did notice in the phpMyAdmin UI after the install that only the server showed the new 4.1.11 version number. The client was still showing 4.0.24, but I didn't worry about it.
    In my Putty window, it states that 4.1 client is installed.

    It looks like the hashing of the passwords doesn't match or something... (?)

    The install restarted the server, but I'm not sure about the client.
    I've rebooted the server, but still get the same problem.

    I tried the advice given here phpmyadmin password hash where I added 'old-passwords' to the [mysqld] section of /etc/mysql/my.cnf
    I also tried the advice by Till given in this post Client does not support authentication protocol requested by server both my libmysqlclient14 & libmysqlclient14-dev are the newest versions. But upon reading it closer, it says that I need to upgrade the libmysqlclient in my ISPConfig setup using the update function. I'm not sure how to do that since ISPConfig was compiled.

    Have you any advice?

    Last edited: Nov 14, 2006
  11. till

    till Super Moderator Staff Member ISPConfig Developer

    This has nothing to do with the new database you added in ISPConfig. I posted the solution in your other thread already.

Share This Page