Disk Monitor

Discussion in 'General' started by john_webX, Jun 29, 2018.

  1. john_webX

    john_webX New Member


    I've got the "problem" that the ISPConfig Site shows the error "Your Hard-Disk has no more space left". But the full disk is a snap file which has to fully occupied. So how am I able to configre the monitoring of isp?
  2. till

    till Super Moderator Staff Member ISPConfig Developer

  3. john_webX

    john_webX New Member

    thanks for the quick reply.

    Here's the output:
    Filesystem Type Size Used Avail Use% Mounted on
    udev devtmpfs 1,9G 0 1,9G 0% /dev
    tmpfs tmpfs 395M 1,1M 394M 1% /run
    /dev/sda2 ext4 49G 7,1G 40G 16% /
    /dev/loop0 squashfs 87M 87M 0 100% /snap/core/4830
    /dev/loop1 squashfs 87M 87M 0 100% /snap/core/4486
  4. ahrasis

    ahrasis Well-Known Member

    It is a common issue but as a solution, I simply removed snapd from my server since I am not using it or relying on it (there is a tool for it in github). However, it is also good to know that the issue is now open since default installation of Ubuntu 18.04 has snapd installed by default.
  5. recin

    recin Member

    I solved it editing file /usr/local/ispconfig/server/lib/classes/cron.d/100-monitor_disk_usage.inc.php on line 77:
    I changed the simfs for squashfs so it goes from:
    $dfData = shell_exec('df -PhT -x simfs | awk \'!x[$1]++\' 2>/dev/null');
    to this
    $dfData = shell_exec('df -PhT -x squashfs | awk \'!x[$1]++\' 2>/dev/null');
    I tried adding squashfs instead of change it for simfs but it didn't work for me.

    As nhybgtvfr comments, you can add squashfs with simfs instead of replacing it with this:
    $dfData = shell_exec('df -PhT -x simfs -x squashfs | awk \'!x[$1]++\' 2>/dev/null');
    Last edited: Jul 5, 2018
    john_webX and ahrasis like this.
  6. nhybgtvfr

    nhybgtvfr Well-Known Member HowtoForge Supporter

    did you set it to $dfData = shell_exec('df -PhT -x simfs squashfs | awk \'!x[$1]++\' 2>/dev/null'); when trying to add it?
    each exclusion needs to be preceded by it's own -x.
    I've just set it on one of my servers to: $dfData = shell_exec('df -PhT -x simfs -x squashfs | awk \'!x[$1]++\' 2>/dev/null');
    and that seems to be working perfectly.

    simfs is for openVZ containers. i'm not using them, so I could get away with just replacing simfs with squashfs, but anyone who does use them will need to add squashfs as another exclusion as I have above, rather than just replace the simfs exclusion.
    recin, ahrasis and till like this.
  7. recin

    recin Member

    You are right, that was my problem. Now I try adding -x squashfs to the original line and It works.

Share This Page