DNS issues - ISP server settings

Discussion in 'Installation/Configuration' started by punto, Dec 4, 2008.

  1. punto

    punto New Member


    I had an issue today where a new zone record would not take on my DNS server. I could create the record but the record would not become active on the server and I could not query the new record via nslookup.
    I then tried to delete the DNS record, but I cannot remove it from the recycle bin, even though it appears to go, it is still there.

    I had to create the primary DNS record on the secondary DNS server, which isnt ideal. I then noticed that under ISP Server the Zonefiles Dir was set to /etc/bind and not /var/named/chroot/var/named as it is on the secondary DNS server. I tried to change it to the correct path, but it reverts back to /etc/bind when I click save. I then compared the permissions between the secondary and the primary servers and the permissions on the primary were different for the directories /var/named/chroot and below. I modified the permissions so that they are the same on both systems but I still cannot change the path under Zonefiles Dir.

    Also I now see in the recycle bins under ISP Manager and DNS Manager that is says the system is updating files - it has been like this for over an hour. The server is still handling DNS queries correctly I just cannot add new zones or delete old ones.

    I have restarted the ISPCONFIG service but to no avail.

    I am running CENTOS 5.2 and the latest release of ISPCONFIG. Server has been fine until I noticed this today.

    Any help greatly appreciated

  2. till

    till Super Moderator Staff Member ISPConfig Developer

    Please redor the steps for the named installation from the perfect setup guide for centos 5.2 and then you can change the path again in ispconfig. The problem occured because centos messes up the bind directory permissions when you unstall a bind update with yum.
  3. punto

    punto New Member

    Thanks a bunch Till, that did the trick! :)

    Should I expect the same to happen to the other box? That is also CENTOS 5.2

  4. rbartz

    rbartz Member HowtoForge Supporter

    Fedora Core 10 - Same Problem with YUM

    I had the same experience when I updated Fedora Core 10 with YUM, the ownnership of /var/named/chroot/var/named and /var/named/chroot/var/run were both changed to "root".

    The solution was to

    chown -R named /var/named/chroot/var/named
    chown -R named /var/named/chroot/var/run

    then reload named with

    /etc/init.d/named force-reload

  5. korbynn

    korbynn Member

    I seem to be missing something here.
    I did all the steps above but no success. What gives?
    CentOS 5.2
    ISPConfig 2.2.32
    I really need the DNS entries to work.:confused:
  6. Turbanator

    Turbanator Member HowtoForge Supporter

    I too am stuck with this. just did a perfect install fedora 10 and my domains all go to the sharedip page. Everything that I can see is identical to the original server. What am I missing? all pri. zones are the same. I did the bind reload from perfect and the chown trick but nothing. I'll pull a windows ritual and reboot the server but I'm lost now.
  7. falko

    falko Super Moderator ISPConfig Developer

    What's in Vhosts_ispconfig.conf, and what's the output of
  8. Turbanator

    Turbanator Member HowtoForge Supporter

    [[email protected] vhosts]# ifconfig
    eth0      Link encap:Ethernet  HWaddr 00:0C:29:0A:01:66
              inet addr:  Bcast:  Mask:
              inet6 addr: fe80::20c:29ff:fe0a:166/64 Scope:Link
              UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
              RX packets:45323 errors:0 dropped:0 overruns:0 frame:0
              TX packets:6113 errors:0 dropped:0 overruns:0 carrier:0
              collisions:0 txqueuelen:1000
              RX bytes:3235931 (3.0 MiB)  TX bytes:2259215 (2.1 MiB)
              Interrupt:19 Base address:0x2000
    lo        Link encap:Local Loopback
              inet addr:  Mask:
              inet6 addr: ::1/128 Scope:Host
              UP LOOPBACK RUNNING  MTU:16436  Metric:1
              RX packets:2010 errors:0 dropped:0 overruns:0 frame:0
              TX packets:2010 errors:0 dropped:0 overruns:0 carrier:0
              collisions:0 txqueuelen:0
              RX bytes:1822742 (1.7 MiB)  TX bytes:1822742 (1.7 MiB)


    # ISPConfig vHost Configuration File
    #         Version 1.0
      ServerName localhost
      ServerAdmin [email protected]
      DocumentRoot /var/www/sharedip
      <IfModule mod_rewrite.c>
        RewriteEngine on
        RewriteCond %{REQUEST_METHOD} ^(TRACE|TRACK)
        RewriteRule .* - [F]
    # Vhost: www.keystononline.com:80
    ServerName www.keystononline.com:80
    ServerAdmin [email protected]
    DocumentRoot /var/www/web1/web
    ServerAlias keystononline.com
    DirectoryIndex index.html index.htm index.php index.php5 index.php4 index.php3 index.shtml index.cgi index.pl index.jsp Default.htm default.htm
    Alias  /cgi-bin/ /var/www/web1/cgi-bin/
    AddHandler cgi-script .cgi
    AddHandler cgi-script .pl
    ErrorLog /var/www/web1/log/error.log
    AddType application/x-httpd-php .php .php3 .php4 .php5
    php_admin_flag safe_mode On
    php_admin_value open_basedir /var/www/web1/
    php_admin_value file_uploads 1
    php_admin_value upload_tmp_dir /var/www/web1/phptmp/
    php_admin_value session.save_path /var/www/web1/phptmp/
    Alias /error/ "/var/www/web1/web/error/"
    ErrorDocument 400 /error/invalidSyntax.html
    ErrorDocument 401 /error/authorizationRequired.html
    ErrorDocument 403 /error/forbidden.html
    ErrorDocument 404 /error/fileNotFound.html
    ErrorDocument 405 /error/methodNotAllowed.html
    ErrorDocument 500 /error/internalServerError.html
    ErrorDocument 503 /error/overloaded.html
    AliasMatch ^/~([^/]+)(/(.*))? /var/www/web1/user/$1/web/$3
    AliasMatch ^/users/([^/]+)(/(.*))? /var/www/web1/user/$1/web/$3
    <IfModule mod_rewrite.c>
      RewriteEngine on
      RewriteCond %{REQUEST_METHOD} ^(TRACE|TRACK)
      RewriteRule .* - [F]

    ISP Manager shows local ip as the server address.
    DNS Manager is showing public ip as the addresses.
    DNS settings show /var/named/chroot/etc/named.conf and /var/named/chroot/var/named

    This was done as a new install of f10 in a VM with repo loads during install as a duplicate of an existing machine so I tried (twice) to make sure that I duplicated everythign exactly as the original machine is set (at least in terms is ispconfig 2) The only files I altered were httpd.conf to alow for rewrite options.
  9. falko

    falko Super Moderator ISPConfig Developer

    dig @localhost www.keystononline.com
    show the correct IP?
  10. Turbanator

    Turbanator Member HowtoForge Supporter

    [[email protected] ~]# dig @localhost www.keystononline.com
    ; <<>> DiG 9.5.1-P2-RedHat-9.5.1-2.P2.fc10 <<>> @localhost www.keystononline.com
    ; (1 server found)
    ;; global options:  printcmd
    ;; Got answer:
    ;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 33606
    ;; flags: qr aa rd ra; QUERY: 1, ANSWER: 1, AUTHORITY: 1, ADDITIONAL: 0
    ;www.keystononline.com.         IN      A
    www.keystononline.com.  86400   IN      A
    keystononline.com.      86400   IN      NS      ns1.keystondns.com.
    ;; Query time: 45 msec
    ;; SERVER:
    ;; WHEN: Tue Jul 28 07:54:11 2009
    ;; MSG SIZE  rcvd: 84
    [[email protected] ~]#
    I may setup an fc9 perfecr setup and see if that works since my current fc9 server has been running great and has been yum'd without any issue. but I wonder why the fc10 doesn't.
  11. falko

    falko Super Moderator ISPConfig Developer

    And does
    dig ns keystononline.com
    show the correct nameservers?
  12. Turbanator

    Turbanator Member HowtoForge Supporter

    yes the name serevers are correct
    [[email protected] ~]# dig ns keystononline.com
    ; <<>> DiG 9.5.1-P2-RedHat-9.5.1-2.P2.fc10 <<>> ns keystononline.com
    ;; global options:  printcmd
    ;; Got answer:
    ;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 1313
    ;; flags: qr rd ra; QUERY: 1, ANSWER: 1, AUTHORITY: 0, ADDITIONAL: 1
    ;keystononline.com.             IN      NS
    keystononline.com.      86400   IN      NS      ns1.keystondns.com.
    ns1.keystondns.com.     44746   IN      A
    ;; Query time: 214 msec
    ;; SERVER:
    ;; WHEN: Wed Jul 29 07:56:42 2009
    ;; MSG SIZE  rcvd: 80
    [[email protected] ~]#
    . 1 note though. this server is replacing an existing live server witht the exact settings, so will these commands give me info on the new server I'm entering these on, or are the commands querying the data from the existing server which is already running? both server are on the same network but only the live server is accessible via the outside right now.

    that sounded confusing....
  13. Turbanator

    Turbanator Member HowtoForge Supporter

    just installed f9 and duplicated everything exactly including permission in named dirs....all I get are sharedip pages.
  14. till

    till Super Moderator Staff Member ISPConfig Developer

    SharedIP has always the same reason: Apache is not able to find the vhost for this request and this is caused in almost all cases by by the fact that the IP in the vhost does not match the ip in dns. Make sure that you select the correct IP for the website and click on save.
  15. Turbanator

    Turbanator Member HowtoForge Supporter

    Till, I checked the same thing since I know about that. But I have the new server set exactly as the same as the original live server. I'll go through again to make sure I didn't miss something. I wonder if I did the setup BEFORE I did a yum update to see if it works....then do the updates at the end. I only say this because my live server is running great and I have 1 at f10 and 1 at f9 without issues and they both are yum updated fully.
  16. Turbanator

    Turbanator Member HowtoForge Supporter

    tell me if this helps.

    after I set everything up, I get an Internal Server error on a domain which is an OsC site. This tells me that the server is finding the correct site dir becasue it's reporting issues with the .htaccess file. I then corrected the httpd.conf for overrides and instead of the Internal Server Error, I get pushed to the sharedip page. So this tells me the server IS going to the correct dir but ends up at the sharedip page, right?

    Maybe that will help jog something that I'm completely lost about...
  17. korbynn

    korbynn Member

    I am following this thread and seem to have everything the same as Turbanator but what I have found is that the appropriate files that are necessary to direct the domain name to the correct web directories are not created by ISPconfig. When I do create the files, ISPconfig would delete them when I am changing the domain settings. It seems that I need more information present to complete the redirection. Looking at the ISPconfig database I find that the DNS entries are not entered properly.

    At this time I need to be pointed to a DNS tutorial so that I can quickly get these domains up and running. Any suggestions?:confused: In the past I would enjoy trouble shooting this problem but at this time I have several domains to get up and running like yesterday.
  18. Turbanator

    Turbanator Member HowtoForge Supporter

    Where do you see that the incorrect entries are in the database? If you can point me there, I'll look on my working live server to see the difference and maybe we can figure this out.
  19. korbynn

    korbynn Member

    The issue that I am running into is:
    1-Create a new domain - ISP Site from ISP Manager - New site
    2-Check Create DNS.
    3-Check Create DNS MX
    4-Save configuration
    5-Go to DNS Manager
    6-Search for DNS entry for just created domain
    7-I can not find the entry.
    8-I go into phpMyAdmin
    9-I find entries in table dns_isp_dns
    10-I cannot find any matching dns entries in any of the other dns supporting tables.
    11-I create the dns files/entries - they do not seem to work
    12-I uncheck Create DNS and Create DNS MX from ISP Site page
    13-ISPconfig also deletes created files/entries for domain.

    ISPconfig will delete created supporting files and entries but will not create them.
    Was working under CentOS 5.2 updated to CentOS 5.3 through OS update manager. This is when it stopped working.

    Working with a fresh CentOS 5.3 installation as my slave DNS among other things named is working but ISPconfig reports that it is not working.:confused: Same for FTP and SMTP sections. This part will need to be resolved soon as I will be starting to host domains on this slave.
  20. till

    till Super Moderator Staff Member ISPConfig Developer

    The centzos update manager is known to mess up the bind directory permissions. Please redo the permission settings fro bind from the perfect setup guide nad then make sure that you set the correct path to the bind files in the ispconfig server settings again.

Share This Page