DNS Server problems

Discussion in 'Installation/Configuration' started by Netscape, May 13, 2014.

  1. Netscape

    Netscape New Member


    I want to use my ISPConfig Server for DNS. So I created a DNS primary zone and configured NS Records and all worked fine. Also the zone transfer to secondary nameserver from our domain provider.

    But if I add a new record to that Zone, I can´t resolve it (tested with dig).
    The entry is shown in the dns config file used by ispconfig (pri.domain.tld) but with dig it doesn´t show me that record. Also a bind service restart does not help.

    Server: CentOS 6.5 with ISPConfig
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    It might be that BIND is hanging. stop bind and then check with:

    ps aux

    if bind is really stopped. If you still find bind / named processes, then kill them before you start bind again.
  3. Netscape

    Netscape New Member

    I tried to stop the named process. There´s no process running after stopping the service.
  4. till

    till Super Moderator Staff Member ISPConfig Developer

    Check the syslog file for named errors.
  5. Netscape

    Netscape New Member

    I didn´t find any errors in syslog files except this ones:
    error (network unreachable) resolving 'ns2.domain.de/A/IN': 2001:67c:1011:1::53#53
    error (network unreachable) resolving 'ns2.domain.tld/AAAA/IN': 2001:67c:1011:1::53#53
    But that´s IPv6 errors and should have nothing to do with my problem.
  6. Netscape

    Netscape New Member

    Here´s my named.conf
    // named.conf
    // Provided by Red Hat bind package to configure the ISC BIND named(8) DNS
    // server as a caching only nameserver (as a localhost DNS resolver only).
    // See /usr/share/doc/bind*/sample/ for example named configuration files.
    options {
            listen-on port 53 { any; };
            listen-on-v6 port 53 { any; };
            directory       "/var/named";
            dump-file       "/var/named/data/cache_dump.db";
            statistics-file "/var/named/data/named_stats.txt";
            memstatistics-file "/var/named/data/named_mem_stats.txt";
            allow-query     { any; };
            recursion no;
            allow-recursion { none; };
    logging {
            channel default_debug {
                    file "data/named.run";
                    severity dynamic;
    zone "." IN {
            type hint;
            file "named.ca";
    include "/etc/named.conf.local";
    zone "domain.de" {
            type master;
            allow-transfer {;};
            file "/var/named/pri.domain.de";
    $TTL        3600
    @       IN      SOA     host.domain.de. email.domain.de. (
                            2014051308       ; serial, todays date + todays serial #
                            7200              ; refresh, seconds
                            540              ; retry, seconds
                            604800              ; expire, seconds
                            86400 )            ; minimum, seconds
    domain.de. 3600 A
    test 3600 A
    mail 3600 A
    host 3600 A
    www 3600 A
    domain.de. 3600      MX    10   mail.domain.de.
    domain.de. 3600      NS        host.domain.de.
    domain.de. 3600      NS        ns2.domain2.de.
    and finally the output from dig:
    ; <<>> DiG 9.8.2rc1-RedHat-9.8.2-0.23.rc1.el6_5.1 <<>> @localhost any ats-dev.de
    ; (2 servers found)
    ;; global options: +cmd
    ;; Got answer:
    ;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 37638
    ;; flags: qr aa rd; QUERY: 1, ANSWER: 5, AUTHORITY: 0, ADDITIONAL: 2
    ;; WARNING: recursion requested but not available
    ;domain.de.                    IN      ANY
    domain.de.             3600    IN      MX      10 mail.domain.de.
    domain.de.             3600    IN      NS      host.domain.de.
    domain.de.             3600    IN      NS      ns2.domain2.de.
    domain.de.             3600    IN      A
    domain.de.             3600    IN      SOA     stage.ats-dev.de. support.agencyteam.de. 2014051308 7200 540 604800 86400
    mail.domain.de.        3600    IN      A
    host.domain.de.       3600    IN      A
    ;; Query time: 0 msec
    ;; SERVER: ::1#53(::1)
    ;; WHEN: Wed May 14 14:24:14 2014
    ;; MSG SIZE  rcvd: 206
    As you can see in pri.domain.de config file, there should be an entry with test.domain.de.

    But no entry with test.domain.de in dig output.
    Last edited by a moderator: Feb 1, 2015

Share This Page