DNS service added later on

Discussion in 'Installation/Configuration' started by bambam82, May 14, 2014.

  1. bambam82

    bambam82 New Member

    I have a 2 server setup.
    1. All services, but mail and DNS
    2. Mail service only

    Before I just used the only service, to organize my DNS. I thought it was a good idea to install the DNS portion and to inject the DNS information myself and use the 'domain provider' as my backups....

    After installing bind as per howto for wheezy and enabling the DNS support in ISPconfig, it doesn't seem to work. It created everything inside ISPconfig, though it doesn't create the files in the /etc/bind/ directory.

    I've created a test server (in LXC, single server, debian wheezy) and the files are created correctly (though with .err at the end, but that is sort of logical due to the recursive checks ending elsewhere).
    Is there something extra that i need to do, to tell ISPconfig that it should create the files etc...
    When creating the Zones in ISPconfig i don't receive any error messages in syslog.

    i hope it makes sense.

    Hint to anyone else. Just install all the service and perhaps don't use them at the moment, though so you can when you want to. :)
  2. srijan

    srijan New Member HowtoForge Supporter


    I will recommend you to update the ISPconfig with new DNS services, download the latest ISPconfg installer from here. In the install directory use code

    Further to use DNS its highly reccomended to use DNS wizard ISPConfig webinterface to make the DNS operations to run successfully
  3. bambam82

    bambam82 New Member


    I'd just like to mention that your solution worked.
    I ran the update and reconfigured the services. Now it is creating the files for the DNS correctly.

    Thanks for your help.

Share This Page