Do Users have to be Unique accross domains

Discussion in 'Installation/Configuration' started by asem34, Nov 27, 2006.

  1. daadams2000

    daadams2000 New Member



    your right, i did have maildir do i need to restart postfix or anyother service?

    Thanks for you help.

  2. daadams2000

    daadams2000 New Member


    I un-checked "maildir" option in ISPConfig, then restarted postfix, then sent a new message to [email protected]. BUT i still get the message delivered to the /var/mail/josh box. and no new message from outlook express.

    what else do i have to change?


  3. daadams2000

    daadams2000 New Member

    No Log

    I have just noticed, even though i have "Save Log" checked...there is NO log file...

    It is set to /var/log/maillog but there is not file/dir with that name.

    Any thoughts ?

    Thanks All
  4. daadams2000

    daadams2000 New Member

    Mail Log

    After i Rebooted the system my /var/log/maillog file cameback.

    In it i see a couple that there is an error locating the ssl file (i did have trouble creating that file) and that the user web1_josh is loggin in OK... here is some of the log....

    Mar 8 00:20:13 web postfix/smtpd[3332]: warning: cannot get certificate from file /etc/postfix/ssl/smtpd.crt
    Mar 8 00:20:13 web postfix/smtpd[3332]: warning: TLS library problem: 3332:error:02001002:system library:fopen:No such file or directory:bss_file.c:352:fopen('/etc/postfix/ssl/smtpd.crt','r'):
    Mar 8 00:20:13 web postfix/smtpd[3332]: warning: TLS library problem: 3332:error:20074002:BIO routines:FILE_CTRL:system lib:bss_file.c:354:
    Mar 8 00:20:13 web postfix/smtpd[3332]: warning: TLS library problem: 3332:error:140DC002:SSL routines:SSL_CTX_use_certificate_chain_file:system lib:ssl_rsa.c:720:
    Mar 8 00:20:13 web postfix/smtpd[3332]: cannot load RSA certificate and key data
    Mar 8 00:20:14 web postfix/smtpd[3332]: connect from[]
    Mar 8 00:20:14 web postfix/smtpd[3332]: 7995A1E8250:[]
    Mar 8 00:20:14 web postfix/cleanup[3337]: 7995A1E8250: message-id=<[email protected]>
    Mar 8 00:20:14 web postfix/qmgr[2731]: 7995A1E8250: from=<[email protected]>, size=1963, nrcpt=1 (queue active)
    Mar 8 00:20:14 web postfix/local[3338]: 7995A1E8250: to=<[email protected]>, relay=local, delay=0.59, delays=0.5/0.03/0/0.06, dsn=2.0.0, status=sent (delivered to mailbox)
    Mar 8 00:20:14 web postfix/qmgr[2731]: 7995A1E8250: removed
    Mar 8 00:20:20 web dovecot: pop3-login: Login: user=<web1_josh>, method=PLAIN, rip=::ffff:, lip=::ffff:
    Mar 8 00:20:20 web dovecot: POP3(web1_josh): Disconnected: Logged out top=0/0, retr=0/0, del=0/0, size=0

    in the /var/mail/josh there is a few emails... but i never get them when i login to outlook express as web1_josh.

    and in the /var/mail/web1_josh there is this message:From MAILER_DAEMON Wed Mar 07 23:25:24 2007
    Date: Wed, 07 Mar 2007 23:25:24 -0500
    From: Mail System Internal Data <[email protected]>
    Message-ID: <[email protected]>
    X-IMAP: 1173323379 0000000001
    Status: RO

    This text is part of the internal format of your mail folder, and is not
    a real message. It is created automatically by the mail system software.
    If deleted, important folder data will be lost, and it will be re-created
    with the data reset to initial values.


    but no messages.

    also, (sorry this is so long)

    forget that [email protected] is getting any mail. I didn't realize that my user in the actually system is david and that was actually getting mail, but the user web1_david is NOT getting his mail.

    Hope someone can help me.

  5. till

    till Super Moderator Staff Member ISPConfig Developer

    Your log output does not look like the normal output of a ISPConfig system. Did you follow one of the perfect setup guides?

    Was there already some email server installed on the server before you installed ISPConfig?
  6. daadams2000

    daadams2000 New Member


    Yes i followed Falko's Fedora 6 setup guide. and No i don't beleive there was any mail server running before hand. This machine was just for web hosting, i had seperate machine to do mail.

  7. daadams2000

    daadams2000 New Member

    Ok, now im just confused...

    I went back to look at he original setup guide (Falko's Fedora 6) and he says specifically to turn on maildir in IPSConfig.

    10.1 Maildir
    dovecot uses Maildir format (not mbox), so if you install ISPConfig on the server, please make sure you enable Maildir under Management -> Server -> Settings -> Email. ISPConfig will then do the necessary configuration.


    So I just turned it back on and restarted postfix /dovcot and no luck.
    but two things i remembered about the actually setup.

    1) when i ran the commands for setting up postfix, I had issues making the SSL cert file,
    2) my postfix/ didn't look exactly like his, so i overwrote my configs with his.

    Is that OK? Or did i screw something up when i did that?

    David - Sorry this is becoming a mess
  8. martinfst

    martinfst ISPConfig Developer ISPConfig Developer

    Sorry, my mistake I think. I tried to reference the Perfect Install and intended to say you need to configure Maildir usage. Apparently you mis-understood my message. My bad. The howto's from Falko/Till should be leading.

    There are some (even recent) threads in the forum to re-create the certs afterwards.

    Who is 'his'? Didn't see any other in this thread. Did you copy it from another thread?

    Looking at the status, something is 'screwed' and I'm not sure if we can quickly recover by means of the forum. Don't know if a re-installation from scratch (including Linux) is an option?
  9. daadams2000

    daadams2000 New Member

    "his" referred to Falko's in his setup guide. he said "it should look like this..." so i copied that.

    Yeah, i might just have to reinstall everything, but im not sure what went wrong.

    Also, if i do reinstall, when i go through the ssl setup, do i use my actuall info (even though i don't "own" a real cert)

    and last question...
    when mail comes into the server, where is ispconfig/postfix supposed to send the mail? I guess i mean what file? right now it goes to /var/mail/username.

    Thanks for you help

  10. falko

    falko Super Moderator ISPConfig Developer

    Please make sure that SELinux is disabled.

    Simply accept the default values. :)

    /var/mail/username is wrong - this is mbox format. But on Fedora you use Dovecot as your POP3 daemon which uses Maildir. This means you must ernable Maildir in ISPConfig, and running
    postconf -e 'home_mailbox = Maildir/'
    postconf -e 'mailbox_command ='
    /etc/init.d/postfix restart
    might not be bad as well.
    If you use Maildir, the mails are stored in HOMEDIR/Maildir, where HOMEDIR is the hoe directory of the user.
  11. falko

    falko Super Moderator ISPConfig Developer

    Well, they are perfect for me. Never had problems with them :)
  12. daadams2000

    daadams2000 New Member

    add user?

    Thanks Falko,

    does that mean i have to create an actuall system user for each email/user in ispconfig so that it will create the homedir/ folder?

    thanks again
  13. falko

    falko Super Moderator ISPConfig Developer

    No, this is all handled by ISPConfig.
  14. daadams2000

    daadams2000 New Member

    reinstalled postfix/dovecot


    Ok, i just removed / reinstalled postfix and dovecot.

    i then used your FC6 Setup guide and everything worked great, i got the ssl cert setup, and my /etc/postfix/ looked just like yours...

    now when i send mail i get "Relay access denied"

    this happened before and i went to the /etc/postfix/local-host-names file and added because it only had and this fixed the problem. I looked this time and everything was there.

    so now ispconfig isn't creating any mailboxes or homedirs i think because the postfix never delivers the message.

    any thoughts.

  15. falko

    falko Super Moderator ISPConfig Developer

    You must enable "Server requires authentication." in your email client.
  16. daadams2000

    daadams2000 New Member

    My fault, i meant when i send mail to my server it is rejected and i get the mail server response 550
  17. daadams2000

    daadams2000 New Member

    Also, (quick side-question)

    what does the
    ISPConfig -> ISP Manager -> ISP Site -> [mailuser login]
    check box refer to?
  18. falko

    falko Super Moderator ISPConfig Developer

    What's the exact error message (also in the mail log)?

    If it is checked, users can log in under http(s)://<ispconfig>:81/mailuser/ and change their email settings themselves.
  19. orasis

    orasis Member

    I went to: ISPconfig Management > System Config >Settings > ISP Manager and erased the User Prefix: Field. now after what I red it feels like the users can't have a "proper" looking username if we wan't to avoid username conflicts.

    Could I use ISPconfig to only work with one domain, keep the Prefix Field (mentioned above) erased ? would this cause username conflicts if no other domain exists ?

    What if a database gets created not from ISP manager > ISP Site > Options > Databases [New], but externaly with a totaly different name than the one ISPconfig creates ? What can go wrong ?

    I've been testing, creating and changing users, databases, sites, and ended up not being able to create a user called "admin" anymore. it says "user already exists" ... for sure I go for an isntallation from scrach.
  20. till

    till Super Moderator Staff Member ISPConfig Developer



    please empty the recycle bin in ISPconfig.

Share This Page