E-Mail _without_ courier and activating maildir

Discussion in 'Installation/Configuration' started by jokuleo, Mar 5, 2006.

  1. jokuleo

    jokuleo New Member

    Hi, first I would like to thank you for this great control panel. I really would like to contribute something but this has to wait, until I got some things done.

    Now the problem:
    That´s not really new in this forum, I found several postings regarding mail failures, but it seems that as a conclusion for most mail problems you propose the installation of courier and the activation of maildir. But I really would like to keep the possibility for setting the mailquotas. With courier and maildir it works without any problems, but using ipopd and imapd is not possible. Uebimiau and a "real" mailclient (I only tested Outlook) give both the "command stream end of..." message in /var/log/mail.log. I installed using the perfect debian sarge setup five times on different computers and got the same error over and over again. First I thought it was caused by using debootstrap for installation to have a minimal system but even with using the installer cd and following the setup instructions extremely careful, nothing but "You cannot login with the username and password entered." from Uebimiau and a failure message from Outlook (I´m going to post it later).

    Here´s my netstat -tap, I think you´ll see that ;)

  2. till

    till Super Moderator Staff Member ISPConfig Developer

    ISPConfig works fine with nbox format and i have some installations with this combination.

    Have you send a test email to the account before you tried to fetch it with pop3?

    After yo send the test email, did you get any errors in your mail log?
    Did the mail end in a mbox file in /var/spol/mail with the name of the email user?
  3. jokuleo

    jokuleo New Member

    OK, I set up another server, because some of my problems were caused by misconfigured and mixed up local Domains like home.lan and home without .lan (I´m trying a lot at the moment with different computers)... The things are working much better and yes, the test mail ends up in the /var/spool/mail/user file. I used Thunderbird and Outlook to fetch the mail and now they want to connect, but there is kind of an authentication failure. Here the /var/log/mail.log:

    Thunderbrid tells me: "Sending of password did not succeed. Mail server domain.tld responded: Bad login".
    Uebimiau same as before: "You cannot login with the username and password entered. Please check your username and password and try again."

    It is NOT my CAPSLOCK or a similar problem :). The password I enter is the same that I used in ISPConfig. I tried several times...
  4. till

    till Super Moderator Staff Member ISPConfig Developer

    Please try to connect with pop3, not pop3s to verify the basic configuration first.

    Please check /etc/password and /etc/shadow if the mailuser has been correctly created.
    Make sure you use the correct username (webX_user) and not the email address to login.

    Which linux distribution do you use?
  5. falko

    falko Super Moderator Howtoforge Staff

    I recommend to use Courier instead of ipop3d. Maildir is the better format comapared to mbox.
    However, if you want to stick with ipop3d: did you reboot your server? Maybe that helps.
  6. jokuleo

    jokuleo New Member

    The user is in both files. I created another one -> shows up in both files -> same problem...

    Using POP3 and not POP3s I get from Thunderbird: "Sending of password did not succeed. Mail server domain.tld responded: Unknown AUTHORIZATION state command"

    /var/log/mail.log is

    Same message postfix logs when trying with Uebimiau.

    The daemons and stuff is running...

    I´m using Debian Sarge and followed the "perfect debian setup".

    Another question: What about getting maildir working with mail quotas? ;)
    Last edited: Mar 5, 2006
  7. jokuleo

    jokuleo New Member


    I really would like to use maildirs (as I described, an installation with courier was no problem at all, everything worked wonderful), but if I got the forums right, the quota-function of the mailbox will then disappear (and yes, it really happens :(). That´s not THAT bad, but I really would like to have mail and webspace NOT get checked together.
  8. till

    till Super Moderator Staff Member ISPConfig Developer

    Which username have you used in thunderbird?

    The error you posted occurs if you use the email address as useranme instead of the correct username in the format "web1_username".
  9. jokuleo

    jokuleo New Member

    So, I have to use the mail address when using Uebimiau and the username when connecting with a local mail client? Good to know! Nevertheless that´s not the problem here. I tried every combination of name, username, mail address and even some bad words ;). The system keeps telling me the same message.

    I´m now going through all the config files again, but (don´t get me wrong) is it possible that I have to change something of the perfect setup when NOT using courier ? As I said above: Just installing courier causes everything to work as expected! I changed nothing more than the maildir option...

    By the way thanks for your help :) - that´s real support!
  10. falko

    falko Super Moderator Howtoforge Staff

    I've had this problem with ipop3d myself, but not on all installations. And I know that lots of other people have this ipop3d problem, too. Sometimes it's working, sometimes not. Unfortunately I don't know why it's doing this. But I'm using Courier and am quite happy with it. :)
  11. jokuleo

    jokuleo New Member

    Hmm, that´s not exactly what makes me quite happy, but since I won´t spend all my time on this perhaps I´m going to install courier and perhaps building myself a little extra script for keeping track of the mail quotas.

    But before I do that: What about the comments on page 4 of the perfect debian sarge setup? There is mentioned to just do the following after setting up the postfix and security stuff (as far as I understood what "anonymous" wrote there):

    I´m going to test that, but what´s your opinion on this?
  12. falko

    falko Super Moderator Howtoforge Staff

    It has always been working for me like I described in the tutorial, without the comments. :)
  13. jokuleo

    jokuleo New Member

    The workaround described before did not work for me, netstat -tap output seems ok but when trying to use for example the smtp port I got an error concerning symbolic links (and such a symbolic link was part of the tip from "anonymous"). But nevertheless - after setting up the whole thing again two times it seems to work now. One problem was obviously that Debian Sarge in some cases doesn´t like ipopd using insecure connections, what was causing the "Unknown AUTHORIZATION state command" error. I found out that if you want to connect to ipopd using "pure" POP3 you have to create a file /etc/c-client.cf and fill in two lines:
    Yes, you´ll need the first line, Sarge won´t believe you if trying without. :rolleyes:

    I think that my problems were primarily caused by this "security feature" of Debian Sarge. I can remember that first I used Uebimiau and Outlook (POP3), what could not work without /etc/c-client.cf. Then I changed some options and tried again... nothing... changing again... surely I changed so much that when it came to try a secure connection with POP3s most of the options were changed and what should have been working before couldn´t anymore... because of me searching the error in the config files. :eek:

    Possibly some deb package is changing this "strategy" of Sarge, so it would make sense, that some people have problems with their setup and others have not. I´ll keep an eye on this.

    This blog entry saved me from staying awake the whole night:

    And here a link were the c-client.cf-file is mentioned (Number 35):

    Thanks again for the great help
    Last edited: Mar 7, 2006

Share This Page