Email to wrong box

Discussion in 'Installation/Configuration' started by rbartz, Nov 25, 2008.

  1. rbartz

    rbartz Member HowtoForge Supporter

    Problem: Email for [email protected] (NOT a real user) gets put into [email protected], a real user with username jim. is a domain we host.
    We have several virtual domains on a server. A lot of mail users. We turned off the ISPConfig prefixing for email users from the beginning because a lot of the accounts were being moved from another server and we wanted to use the same usernames.

    One email address is [email protected] username jim. This is the ONLY "jim" on the server, there are no others. jim is the admin account for, but he is not an email catchall.

    Mail for [email protected] (NOT a real user or email address or even an alias!) is sometimes put into jim's mailbox. Since it is always spam, it makes jim mad and gives me a headache... :)

    There are several other accounts where common names are used, even where email addresses use the same names for different domains and addresses (SO many "[email protected]"), but this is the only domain it affects. Both are vitural, there is no mydomain setting in Postfix seems always to reject mail to non-existent users. The MX record in the DNS points to the domain names as the MX domain.

    Any ideas? Thanks!

  2. falko

    falko Super Moderator ISPConfig Developer

    If you have removed the username prefixes and there is a system user "jim" on the system, then all emails for [email protected], [email protected], etc. will go to the mailbox of the system user "jim". That's why username prefixes are enabled by default in ISPConfig.

Share This Page