empty recycle bin + commit changes immediately

Discussion in 'General' started by Ovidiu, Jan 18, 2006.

  1. Ovidiu

    Ovidiu Active Member

    hi guys,

    I know there are plenty of "empty the recycle bin" posts around but I still have a problem with that.

    Yesterday I deleted a DB called web20_db1 and created a new one called web20_db2. I clicked on delete recycle bin, went again to the bin and the DB is still there... I tried connecting to the new one and still no lock...

    since yesterday nothing has changed...
    where to look and what to do?
    whats the script to commit changes? how can I test if its not working?
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    Generally, an item can be removed from the recycle bin when the status field is empty.

    Did you have any errors in the ISPConfig logfile?

  3. Ovidiu

    Ovidiu Active Member

    no errors in /home/admispconfig/ispconfig/ispconfig.log - so what can I do? I now still habe web20_db1 and web20_db2 in the recycle bin and the web20_db3 I created this morning is there in my ispcfg panel but it was not created I can't see it with phpmysql, but I can still see the other 2 DBs...
  4. falko

    falko Super Moderator Howtoforge Staff

    Please post the output of
    ls -la /root/ispconfig
    and also of
    ps aux
  5. Ovidiu

    Ovidiu Active Member

    the results are:

  6. Ovidiu

    Ovidiu Active Member

    text too long for one post, heres the rest:

  7. Ovidiu

    Ovidiu Active Member

    heres the last bit:

  8. falko

    falko Super Moderator Howtoforge Staff

    Looks ok. Can you post an SQL dump of the isp_isp_datenbank table?
  9. Ovidiu

    Ovidiu Active Member

    is this what you need? I have to leave now for the next 2 hours,

  10. falko

    falko Super Moderator Howtoforge Staff

    The status fields of the web20 databases aren't empty which means that the ISPConfig backend did not do anything. I had a closer look at the processes you posted and realized the the ispconfig_wconf daemon isn't running.
    I guess /home/admispconfig/ispconfig/.run is existing?

    Please restart ISPConfig:
    /etc/init.d/ispconfig_server restart
    The problem should then disappear.
  11. Ovidiu

    Ovidiu Active Member

    did what you said, now here is the new sql content:

    and indeed it deleted web20_db1 and web20_db2 but it did not create web20_db3. any further suggestions?

    I changed the db password for web20_db3 and saved inside ispcfg panel and that did the trick :)

    thx a lot.
    Last edited: Jan 18, 2006

Share This Page