Enable Directory Listing

Discussion in 'Installation/Configuration' started by smakynet, Apr 4, 2009.

  1. till

    till Super Moderator Staff Member ISPConfig Developer

    Thats strange indeed. I add this to the bugtracker to find out what might cause this.
  2. bob_the_stripper

    bob_the_stripper New Member

    what works for me

    ISPConfig 3 > Website > Options > Apache directives :

    <Directory "/var/www/clients/client1/web3/web/123">
    Options +Indexes
    can now list files folders in:

    (I have PHP enabled)

    (using Fedora 10 perfect server, ISPConfig 3 => thanks Falko :) )
  3. drfalken

    drfalken New Member


    i can confirm the same problem, it doesn´t matter what combination of directory commands (symlink or not) i put in the conf, directory-listing (+indexes) only works if php is enabled.

  4. bhwong

    bhwong New Member

    I have the same problem with getting the url to list files too. No matter which conf files I enabled, it's always error 403. So where do you guys enable the PHP and which PHP did you guys enabled?


    Boon Hong.
  5. bhwong

    bhwong New Member

    I solved the listing problem. In ISPConfig3, go to System > Server Config > "Server name" > Web Tab > Security Level : High > Medium
  6. angela

    angela New Member

    Ministry of Resurrected Threads

    Sorry to revive an old thread but has any progress been made on this bug about Apache configuration to allow indexing of directories?

    I want to use only perl; I want to allow indexing on specific directories.

    And the only way to do it, as posters pointed out 9 months ago, is to enable php on a site. What progress?
  7. amorgner

    amorgner New Member


    After playing around with the options and directives mentioned in this thread, I can confirm that directory listing works only if PHP is enabled.

    Not good. Takes too long to figure out.
  8. QuetzalFirst

    QuetzalFirst Member

    Dont work for me
    <Directory "/var/www/clients/clientX/webY/web">
    Options +Indexes
    No .htaccess and no index.php or index.html and i only get defaut server page. When i add index.html i got that page
  9. Adam Waldrop

    Adam Waldrop New Member

    I recently had the same problem on a different server hosting ISPConfig..
    What worked for me was I had to "chmod go+r ." in the directory I wanted to have read access to, apparently it doesn't list unless everyone can read from that directory, no brainer there I guess :)

Share This Page