Error in

Discussion in 'Installation/Configuration' started by martinhe, Jun 16, 2022.

  1. martinhe

    martinhe Member

    This update script misuses the hostname server for the integrated encryption services. However, hostname has nothing to do with the ispconfig domain or server services.

    My server's hostname: server4.domain1.tld
    Domain of ispconfig and services:
    • https: //ispconfig.domain2.tld:8080/
    • smtp: //ispconfig.domain2.tld:587/
    • imap: //ispconfig.domain2.tld:143/
    • ftp: //ispconfig.domain2.tld:21/

    When I run under "Create new ISPConfig SSL certificate (yes, no) [no]: yes".

    • How it works now: This incorrectly generates a certificate for the server's hostname (server4.domain1.tld). However, the server's hostname has nothing to do with the service domain.
    • How it should work properly: It should look in the downloaded ispconfig DB dump, read the ispconfig domain (ispconfig.domain2.tld) from it, and generate a certificate for it. Not for hostnames that have nothing to do with the ispconfig domain.

    I can help or invest time in solving this error. It's important to me. Now this prevents me from using the internal "ISPConfig SSL" feature.
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    So it works as it is intended to work as the hostname is what the certs shall be based on.

    This assumption is wrong, the exact opposite is the case. The system responds to other systems that contact it with its hostname, so the SSL certs for all services should be and are based on the hostname.

    So it currently works exactly as it should work.

    That's not how it should work.

    Basically, you use the wrong hostnames on your systems which results in SSL certificates based on these wrong hostnames. The solution is to correct your hostnames.

Share This Page