Error installing with Suse10 on x64

Discussion in 'Installation/Configuration' started by SeaWolf, Dec 7, 2005.

  1. traxxx

    traxxx New Member

    Check the syntax

    I had a problem fora while on a Slack box, but eventually figured out the problem: I was taking all the instructons literally ;)

    From one of your previous posts:

    "Try to use: --with-openssl or --with-openssl=/path/to/openSSL/from/suse

    Tried same as the last mod but change with --with-openssl
    here is the error msg:
    configure: error: Cannot find OpenSSL's libraries
    ERROR: Could not configure PHP

    and now with --with-openssl=/usr/include/openssl
    here is the error:
    configure: error: Cannot find OpenSSL's <evp.h>
    ERROR: Could not configure PHP

    and evp.h is in /usr/include/openssl :("

    Turn this
    into this:

    As long as you have the file "evp.h" on your system at that path, this should take care of your problem.

    Good luck.
  2. MorisatoKeiichi

    MorisatoKeiichi New Member

    OpenSuSE10.3 x64

    I receive the same error.
    OS: OpenSUSE 10.3 x64
    Installed Packages: openssl, openssl-32bit, libopenssl-dev
    unchanged compile-file gives
    when I change to "--with-openssl-dir=/usr/include/openssl" the error is
    But evp.h is definitely in that directory.
    What can I do?
  3. falko

    falko Super Moderator ISPConfig Developer

    Please try this:
    yast -i openssl-devel-32bit

Share This Page