FC5 & Samba

Discussion in 'Server Operation' started by Tosh, Aug 13, 2006.

  1. Tosh

    Tosh New Member

    I have a few problems making my samba work on fc5
    1) I had to put SELinux off, this because otherwise I could mount the shares. Is there no way to keep SELinux on and access my shares.
    2) The shares have some permission problems.
    Take share1 which whe I log in gives through "ls -l" that me:me is the owner and that I therefor have full rights. Nevertheless when I mount (using cifs) it on my laptop (also running fc5), and I do again "ls -l" it gives somebody;someone.
    I found out this has to do with UID, but on my laptop I have some guest users, as I sometimes need to borow it out, these users are only on my laptop, but there UID corresponds to my server UID of me.
    Is there anywhay I can get around this?
  2. falko

    falko Super Moderator ISPConfig Developer

  3. Tosh

    Tosh New Member

    Thank you, falko. I have read this part and tried to disable only SELinux for samba, nevertheless it refused working untill I totally put SELinux off. I have read some other articels about this problem and everyone reports the same, so I think this is a bug.
    Anyway I could work if this was the only problem. I still can't get around the UID problem, point 2 of my original post.
    As I now see that even my Windows box is giving problems about this. It can create the folder, but is not owner, and therefor loses all wrinting and administrative rights.
  4. till

    till Super Moderator Staff Member ISPConfig Developer

    Have you tried to force owner and group of the files to your own user in the smb.conf for this share?
  5. Tosh

    Tosh New Member

    Yep, have done that, but still it show on the local pcs the wrong user while on the server it shows the right one.
    Maybe the mount command is wrong? I use mount -t cifs -o username=User //place/tomount /local/location
    Do I need to include some other options maybe?
    And on my WinXP Pro it also gives the same problem, is there any config I need to change there too?

Share This Page