Fedora 10 - Virtual Users And Domains With Postfix, Courier etc

Discussion in 'Server Operation' started by j.smith1981, Oct 6, 2009.

  1. j.smith1981

    j.smith1981 New Member

    I am having trouble with the above tutorial.

    I went through the perfect sever up to ispconfig setup (didnt need that so dont see the point when I get what I need through webmin (actually barely use that so there's no point in even having that, its just sometimes i prefer to use a web interface).


    I setup the [email protected] (as an example so I could understand whats going on as thats all I would be using but it just doesnt seem to want to work.

    I made sure I followed the steps exactly (except the virtual domain it gave I saw it as being the one I wanted to use not example.com or whatever it was), changed that to jeremysmith.me.uk (my real online domain name as it where).

    I get the following error though any suggestions as how to work out whats actually happening?

    I have redone the password for the email user countless times, 'secret' using encryption but just nothing seems to be working.

    Can someone help?

    Any help would be wonderfull.

  2. falko

    falko Super Moderator ISPConfig Developer

    The "Perfect Server" setup is not compatible with the "Virtual Postfix" setup. Please don't mix them.
  3. j.smith19810808

    j.smith19810808 New Member

    So sorry to create another account for this same error guys.

    Feel free to remove my old login (cant seem to login using that anymore sadly).

    But I have a more convincing error message in maillog regarding this, this is as follows:

    I would really appreciate some help with this, could this be to do with a the SSL part?

    Hence the FAILED message in the above log?

    As I said any help is greatly appreciated.

    Thanks again,
  4. falko

    falko Super Moderator ISPConfig Developer

    Please add fc10redhat.jeremysmith.me.uk to the mydestination line in /etc/postfix/main.cf and restart Postfix.
  5. j.smith19810808

    j.smith19810808 New Member

    Ok this is what keep getting, cant work out where to change anything to get it working, so again any help is appreciated, will give one or 2 things a go though, just to see if I can get any further with it.

    But any help to check against my suspicions would be wonderful thanks ever so much falko:

    I think its got something to do with the fact I havent put in fc10redhat.jeremysmith.me.uk where i put in mail.jeremysmith.me.uk

    But anymore help would be wonderful!

    Also is there any reason I should be getting this error when I run '/usr/bin/freshclam', I get this error:

    Can someone help me with this please?

    Kind regards,
  6. j.smith19810808

    j.smith19810808 New Member

    Ok I got rid of the lock problem, was a simple as creating the directory for it and allowing access to it as you'd exepect but this error keeps cropping up:

    In the sense that the security part keeps bringing up a failed message and its being queued as it explains above, is there any means around this please?
  7. j.smith19810808

    j.smith19810808 New Member

    I am here not say now I have given up on this now.

    Its not working, so just going to admit defeat.

    Really should as a suggestion, explain your steps a bit more clearly

    Well allot if I am honest, sometimes you do, but then for the most part you dont.

    Just a criticisim, thats why I find your tutorials rather missleading.

    I get the jist and go elsewhere like with this.

    I will now be looking for other tutorials to allow me to setup a domain server, atm I am trying qmail.

    Really find your tutorials rather missleading for the most part.
    Last edited: Feb 17, 2010

Share This Page