Fedora 8 on a Laptop

Discussion in 'Installation/Configuration' started by cybereatl, Jan 31, 2008.

  1. cybereatl

    cybereatl Member

    Hi folks, am turning myself 100% to Linux, and I have some little issues with sound, Wlan and Web camera:

    Sound: it shows some devices, but no sound at all, there is a list:

    0. HDA Intel
    1. Realtec ALC268
    and shows up another 3 with ALC268 but no sound at all.

    Wlan: there is any way to reduce time on boot to determine ip for wireless adapter? in some wau to skip it??? also how do I remove asking for password every single time that it's connecting to my network, that it's odd

    Webcamera: I got a problem due to webcam it's a USB device and no scanner or camera software can detected, I've install some ms software and still comes out as a USB Camera.. how do I configure my webcam built in computer??

    That will be all, any hints will be appreciated.

    Kind regards :cool:
  2. daniel_curry

    daniel_curry New Member


    Wlan: there is any way to reduce time on boot to determine ip for wireless adapter? in some wau to skip it??? also how do I remove asking for password every single time that it's connecting to my network, that it's odd


    In the network configuration tool there is a checkbox for the device to be active at boot time or not. Remove that checkmark.

    If you choose the next checkmark, you can configure the network device to be startable by a user, rather than root/su.

    I have no answers regarding the sound and camera comonents.

  3. topdog

    topdog Active Member

    You can use networkmanager for your WLAN it will not start on boot only when you login, and for the password you can use the wallet to store the password, but you will have to open the wallet for network manager to access your WPA details each time it needs to connect you to a WLAN
  4. cybereatl

    cybereatl Member

    I've tried removing check mark on boot, but Fedora has deactivated both network cards, and I've to restart the service and sometimes need to restart service!! So it's not a good option.

    Going with network manager also force to activate wireless card to get connected plus you need to give password as well....

    I think should be any way to do it automatically without setting passwords, for example on any home network with basic security :rolleyes:
  5. o.meyer

    o.meyer ISPConfig Developer ISPConfig Developer


    deactivate the network in all runlevels, and enable the networkmanager & networkmanager dispatcher (only) in runlevel 5. Additionally you can use pam_keyring to automatically open your gnome-keyring after login. Please have a look at http://www.howtoforge.com/installation-guide-fedora8-desktop-p3 -> step 4.5.1, 4.5.2 & 4.10.

    Best regards,

    Last edited: Feb 7, 2008
  6. cybereatl

    cybereatl Member

    Great tip Olli,

    It works like charm, now I've a fast boot :)

    I'll keep working with sound and USB Camera.

    Regards, :D
  7. linuxidiot

    linuxidiot New Member

    # lspci | grep -i audio

    Audio device: Intel Corporation 82801H (ICH8 Family) HD Audio Controller (rev 03)

    if you have the same audio controller family from intel 82801H revision can be 2 or 3 if so follow up the rest of the procedure. With that i managed to get my sound working on fedora core 8 on Asus Laptop.

    Following a post in other forum, changed modprobe.conf to be similar to the following:

    alias char-major-116 snd
    alias snd-card-0 snd-hda-intel
    options snd-hda-intel model=lenovo
    # OSS/Free
    alias char-major-14 soundcore
    alias sound-slot-0 snd-card-0
    # card #1
    alias sound-service-0-0 snd-mixer-oss
    alias sound-service-0-1 snd-seq-oss
    alias sound-service-0-3 snd-pcm-oss
    alias sound-service-0-8 snd-seq-oss
    alias sound-service-0-12 snd-pcm-oss

    Also added /etc/modprobe.d/alsa-base file with only the following line:
    options snd-hda-intel model=lenovo

    But before trying this procedure make a backup copy of your modprobe.conf and try it out.

    Mohan :cool:
  8. cybereatl

    cybereatl Member

    In some way am lost, am unable to find proper driver, check it out...

    Attached Files:

  9. linuxidiot

    linuxidiot New Member

    See follow the steps i have mentioned

    Step 1 in terminal run

    lspci | grep -i audio <--------- will give u the audio controller name

    if the intel card in your machine matches the card which i have mentioned then follow the remaining steps.

    Step 2

    Backup: cp /etc/modprobe.conf /etc/modprobe.conf.bak

    vi /etc/modprobe.conf

    Add those paramenters which i have mentioned.

    Step 3

    vi /etc/modprobe.d/alsa-base

    create that file with the single line i have mentioned above.

    Thats it restart your system
  10. JoeBlacken

    JoeBlacken New Member

    Good job linuxidiot

    I have Toshiba Satellite x205-S7483, same sound chipset, and it worked great for me. :D :D :D

    Thank you linuxidiot :cool:

Share This Page