Fedora Core 2 - DNS Not updating

Discussion in 'Installation/Configuration' started by jackaltx, Mar 27, 2006.

  1. jackaltx

    jackaltx New Member

    I have the laters vers 2.2.0 installon a Fedora Core 2 box

    THe DNS does not seem be be updating. THe bind is chrorrted

    I tried to change the /etc/bind to /var/named/chroot/var/named but it would not change in the setup area. So I put a symbolic link in and made sure the I was 777'd from the /var/named/chroot down to the directory.

    The Sendmail and Apache stuff looks good.

    Suggestions please? How do I look at the error messages? Nothing is showing up in the /var/log/message or in /root/ispconfig/httpd/logs. I am not sure what even would cause it to try to write the DNS out again.

    my comments so far are perhaps make you links in the "/home/www" betwween your internal key and the site name relative links. that would allow simpler transport.
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    The logfile you are searching for is /home/admispconfig/ispconfig/lib/ispconfig.log

    Did you got any errors during installation or do you modify the ispconfig database manually. The error you describe appears when the setup did not finish completely and the setup values where not written to the database correctly.

    Thats exactly what ISPConfig is doing.
  3. jackaltx

    jackaltx New Member

    Thanks for the quck reply

    hmm...no log file there

    root@daddy lib]# pwd
    [root@daddy lib]# ls
    app.inc.php banner.inc.php classes config.inc.php copyright.inc.php go_info.inc.php help index.php lang plugins preload.inc.php session.inc.php
    [root@daddy lib]#

    No I have not edited this one by hand. I did a test install on a RC4 and tried to get familiar with it before this.

    as for the links....this one appears to be absolute.

    [root@daddy lib]# ls -l /home/www
    total 80
    lrwxrwxrwx 1 apache web7 14 Mar 27 01:23 forums.g2interactive.com -> /home/www/web7
    drwxr-xr-x 3 root root 4096 Mar 27 00:30 localhost

    I would appreciate any help. I have not edited any of the configuration files. I set some defaults in the isp_isp_user table .

    I am sure I have cocked up something, Suggestions Please????
  4. till

    till Super Moderator Staff Member ISPConfig Developer

    Sorry, the correct log path is: /home/admispconfig/ispconfig/ispconfig.log
  5. jackaltx

    jackaltx New Member

    it is late here...i found that fle

    grep WARN ispconfig/ispconfig.log
    18.02.2006 - 18:18:48 => WARN - Cannot Open File: F:\server\www\ispconfig\install_ispconfig\ispconfig/users
    26.03.2006 - 23:47:15 => WARN - /root/ispconfig/scripts/lib/classes/ispconfig_system.lib.php, Line 696: WARNING: could not /etc/rc.d/init.d/httpd restart &> /dev/null

    The only thing I see is a bunch of "symbolic link failures", which does surprise me

    and a few of these
    27.03.2006 - 01:22:52 => INFO - Signalfile Set: insert
    27.03.2006 - 01:23:08 => INFO - Signalfile Set: update
  6. jackaltx

    jackaltx New Member

    ok .... got it and this will affect all users of a chrooted named

    well, this was one of those experiences.....you know the ones you think you come away smater, but you are not sure.

    first...you cannot use the webform to change that place were the dns stores the name files. Not sure why, but I had to edit it in the "isp_server" table.

    Then after I changes one of the soa values in a record the files were generated...butttttttt named will not start the /etc/named.conf has absolute path variables in it and named is jailed ina chroot.

    to make that work I did this

    from the /root/ispconfig
    find . -exec grep "/var/named" {} \; -print
    directory "/var/named";

    I edited that file (removeing the {BINDDIR} variable to

    options {
    pid-file "/var/run/named/named.pid";
    directory "/var/named";
    auth-nxdomain no;

    and now I got named working

    THe earlier issues with symbolic links are becuase webilizer ran and reduces logs for the domains I had on their just before I installed the software.

    ALSO...those links are NOT being made relative by the program. It is probably not an issue for most people.

    As I have given help...I sure could use a little tutoria on how to read/traverse these "tree" tables. They look really cool and I would like to see if they might be usefull in another effort.

  7. falko

    falko Super Moderator Howtoforge Staff

    I'm sure this is a permissions problem. The ISPConfig web interface uses PHP's realpath() function to validate the path you put in. The web interface runs as an unpriviledged user; if the directory/file you put in is readable only by root, then realpath() will return FALSE, and ISPConfig continues to use the old value.
  8. jackaltx

    jackaltx New Member


    You were absolutely correct.

    the /var/named directory was 750.....put it to 755 and now the DNS is just as happy as can be and the field in the database updates correctly.

  9. Blu

    Blu New Member


    Erm, can anyone post their copy of this... have deleted it by mistake trying to fix my FC5 DNS not updating issue :rolleyes:
  10. Blu

    Blu New Member


    Ok, fixed it guys ... updated ISP Config and it seems to have reappeared. Still having this DNS update issue tho .... it seems to create the httpd vhosts file, however, does not update the DNS records. Anyone got any ideas? ..... the permissions are changed to 755 in the chroot jail.

    If it helps, my mysql database seems to be updating ok, just the DNS records are not writing. Can't find any clues in the /var/log/message file either - only a load of samba report messages.

    Last edited: Nov 28, 2006
  11. till

    till Super Moderator Staff Member ISPConfig Developer

    Do you get any errors in the ISPConfig logfile /home/admispconfig/ispconfig/ispconfig.log ?
  12. Blu

    Blu New Member

    grep error ispconfig.log returns:
    27.11.2006 - 23:25:54 => INFO - /root/ispconfig/scripts/lib/config.lib.php, Line 1058: cp -fr /root/ispconfig/isp/error_en /var/www/web9/web/error

    The file starts at 4pm yesterday, there's a lot of INFOs but no ERRORs.

    I can also see references to the subdomains I was trying to create, however, they are all linked to either xferlog.mysubdomain.mydomain.co.uk or maillog.....
    Last edited: Nov 28, 2006
  13. falko

    falko Super Moderator Howtoforge Staff

  14. Blu

    Blu New Member

    removed the .ispconfig_lock file and all seems to be working quite well now... cheers guys.
  15. Blu

    Blu New Member

    well .... maybe not quite well.... seems to be creating the DNS now and pulling them up ok, however, i've maybe now run into a problem with my vhosts as it's pulling up the "This is a shared IP" page instead of the "welcome to blah.com" page.

    It's creating the DNS records, it's creating the /var/www/webx and symbolic link of the domain name web files...

    It's even created the virtual hosts in /etc/httpd/conf/vhosts/Vhosts_ispconfig.conf

    Not sure if it makes a difference but I did find this line in the httpd/error_log file a few times:

    [Tue Nov 28 21:53:06 2006] [error] [client xx.xx.xxx.xxx] File does not exist: /var/www/sharedip/favicon.ico

    *** UPDATE: ok, seems to work fine when i create a site with an internal IP, just not external. Will try and create a site with a registered domain on the internal IP and give it some time to propogate and let you know what happens. ***

    *** ANOTHER UPDATE: Works fine with just using internal IP - woohooo***

    Thanks again for all your help guys!

    Last edited: Nov 29, 2006
  16. falko

    falko Super Moderator Howtoforge Staff

    Yes, in ISPConfig you must use the IP address that you see in the
    output. But for DNS records you must use your public IP address, otherwise users that are not in your local network can't visit your web sites.
  17. VibroMax

    VibroMax New Member

    Please what was the solution to this problem ? Everything seems to be fine with my ispconfig just that ispconfig is not updating named.conf anymore. The path to this file and the zone files is correct in the web management interface.
  18. falko

    falko Super Moderator Howtoforge Staff

    Which distribution are you using? Are there any warnings in /home/admispconfig/ispconfig/ispconfig.log?
  19. VibroMax

    VibroMax New Member

    I'm running CentOS 4.6

    I have some warninings in /home/admispconfig/ispconfig/ispconfig.log

    05.10.2008 - 22:51:31 => WARN - /root/ispconfig/scripts/lib/classes/ispconfig_postfix.lib.php, Line 289: WARNING: could not postmap hash:/etc/postfix/virtusertable

    05.10.2008 - 22:51:31 => WARN - /root/ispconfig/scripts/lib/config.lib.php, Line 2414: WARNING: could not httpd -t
    &> /dev/null

    05.10.2008 - 22:51:31 => WARN - /root/ispconfig/scripts/lib/config.lib.php, Line 2425: httpd syntax seems to contain
    errors, reloading with old configuration

    However, I made changes in ispconfig dns manager (as I read in one of the posts) to one of my sites and when I checked /etc/named.conf I noticed ispconfig has written to the file.
    Please can you give a pointer to what is causing the errors and the reason ispconfig stopped writing the /etc/named.conf ?
  20. falko

    falko Super Moderator Howtoforge Staff

    What are the outputs of
    ls -la /var/named/chroot/
    ls -la /var/named/chroot/var/
    ls -la /root/ispconfig
    ls -la /etc/httpd/vhosts

Share This Page