Fetchmail Socket Error

Discussion in 'Installation/Configuration' started by oNdsen, Oct 24, 2016.

  1. oNdsen

    oNdsen New Member

    Hi All
    I have a Problem with Fetchmail.
    The Goal is to Grab Mails via IMAP SSL from an external Server to an internal Mail Account.
    The Config looks good either in ISPConfig3.1 also on the Linux Side (Debian 7 with all Patches).
    On network Side, the Firewall is open and the Packet is leaving our Datacenter to the correct Mailserver.
    In the same Network as the Server is (with Fetchmail Config) i can connect to the IMAP Account and see all Mails.
    When i run /server/scripts/run-getmail.sh i receive the following Message:
    getmail version 4.46.0
    Copyright (C) 1998-2012 Charles Cazabon.  Licensed under the GNU GPL version 2.
    SimpleIMAPSSLRetriever:[email protected]@mail.domain.tld:993:
    mail_server_domain_email_domain_tld.conf: socket error ([Errno 101] Network is unreachable)
      0 messages (0 bytes) retrieved, 0 skipped
    Does anyone knows this Problem and give me a Hint to solve it?
    Thank you very much for any Help, im really lost here...
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    Check the file
    mail_server_domain_email_domain_tld.conf in /etc/getmail. The mailerver that is defined there to fetch mail from can not be reached.
  3. oNdsen

    oNdsen New Member

    the given mailserver is imap.hispeed.ch with port 993
    its a running mailserver form an isp in switzerland.
    i also tried it with a gmail account - same error.
    i think there must be a problem with the local server, but i dont know where it could be.

    I just tried several Servers. No one seems to work.
    First Test: telnet to localhost (defined hosts entry):
    root@web02:~# telnet imap.domain.tld 143
    Connected to web02.domain.tld.
    Looks good, telnet is working.
    Lets check an external Server:
    telnet imap.hispeed.ch 143
    Trying 2001:730:3e10:0:213:46:255:24...
    telnet: Unable to connect to remote host: Network is unreachable
    root@web02:~# telnet mail.cyon.ch 143
    ^C <- canceled later...
    root@web02:~# telnet mail.cyon.ch 993
    ^C<- also canceled...
    Firewall logging activated:
    Firewall looks good.
    Trying to reach a Server from local:
    * OK IMAP4 server (InterMail vM. 201-2260-151-156-20141103) ready Mon, 24 Oct 2016 14:50:50 +0200 (CEST)
    Looks perfect.
    So im absolutely confused.... Any Ideas? :confused:

    Oh man, i just found the Error... Missed the Service in SNAT Config o_O
    Im so sorry and also thankfull for your Input, Till!
    This Topic can be closed :)
    Last edited: Oct 24, 2016

Share This Page