FTP Change location

Discussion in 'Installation/Configuration' started by Dextros, Mar 5, 2015.

  1. Dextros

    Dextros Member

    Sorry i realised i posted this in the wring location. Please delete the old thread under Linux> Installation/Configuration.

    Hi Guys

    I am migrating over from Centos 6.6 to Debian Wheezy on a new server.

    I have managed to get most things working, except FTP.

    On my old server, I ended up changing the directory of /www from /var/www/ to /home/www as I was having space issues.

    Learning from my mistakes, /var is now huge. I have emails working and websites working back in there original place, but i cannot change the FTP location from /home/www to /var/www because;
    1. Directory not inside of web root directory.
    Is this because of the protected folders?

    I removed the FTP user and remade, and it still wants to put /home/www

    Can anyone suggest where to look?

    Kind Regards

  2. till

    till Super Moderator Staff Member ISPConfig Developer

    Most likly the ISPConfig database still contaisn the old paths for the ftp users, or did you change them in the database?
  3. Dextros

    Dextros Member

    Hi Till

    I had already tried to change it in sql, and i just tried again - Table ftp_user.

    While the change sticks, I cannot still get the directory.

    When I log onto ISP, and check, it does show the changed path, but when I press back, it comes up with the same error: Directory not inside of web root directory
  4. till

    till Super Moderator Staff Member ISPConfig Developer

    Did you change all paths for the websites as well (web_domain) table?
  5. Dextros

    Dextros Member

    Oh wow. Thanks. It was the Document root location that helped in the web_domain table.

    Now i have a new error

    Response: 257 "/" is your current location
    Command: TYPE I
    Response: 200 TYPE is now 8-bit binary
    Command: PASV
    Response: 227 Entering Passive Mode (***,***,218,77,125,240)
    Command: MLSD
    Error: Connection timed out
    Error: Failed to retrieve directory listing

    Is this port for passive problem. I can get into FTP via chrome, but its extremley slow to move around the dirs.

  6. Dextros

    Dextros Member

    Its fixed now. I added in PassivePortRange file and restarted. Then added firewall rules to mimic.

    Thank you so much for the software. Do you accept donations!?
    till likes this.
  7. till

    till Super Moderator Staff Member ISPConfig Developer

    We dont have a donation buttton. But if you like to support our work, please consider to buy a copy of our ISPConfig manual http://www.ispconfig.org/page/en/documentation.html or to become a howtoforge subscriber.

Share This Page