ftp not working

Discussion in 'Installation/Configuration' started by mwebb, Jan 10, 2006.

  1. mwebb

    mwebb New Member

    used fc4 the perfect setup.
    installed ispconfig.
    trying to access mikewebb.com via ftp from a windows machine with filezilla.

    the plan here is to allow my web site designer to design the web site with nvu. after hes complete he should be able to hit the "publish" button and the new web site pages are automaticly uploaded to the web site.

    the first step it seems would be to access the web site from outside the lan as admin.

    i can access the web site via the web using http://mikeswebb:81 and log in as admin.

    in ispconfig i have created a web site called mikeswebb and i checked the ftp access checkbox. but i do not have anonymous ftp checked.

    a pinhole thru the firewall was created (port 21), pinholes for port 80 and 81 were created and work so i thing the ftp pinhole is working as well.

    when i try to connect via ftp to mikeswebb.com filezilla says "connecting to mikewebb.com" after a time it says "unable to connect".

    anyone have an idea what i should do ??
  2. falko

    falko Super Moderator Howtoforge Staff

    Does it work from within your network?
  3. mwebb

    mwebb New Member

    i've gone alittle farther than when i asked for the help. i am now able to log in to the ftp site. i have nvu setup to publish the files. the only problem now is that after i publish the new index page then in firefox go to mikeswebb.com it still brings up the old "welcome to fedora core" page. didn't know if the index page was suppose to go to the web folder or the folder above it, placed it in both locations and still no luck.
    ps have hit the refreash button in firefox many times.
    deleted out the "welcome to fedora core" page, nothing in web folder except new index.htm. still comes up with "welcome to fedora core".
  4. mwebb

    mwebb New Member

    to answer your question though. on the inside admin still doesn't work (outside ether) says the password is incorrect. on the outside a created a new (reseller ?) and can access the ftp site (inside or outside).
  5. till

    till Super Moderator Staff Member ISPConfig Developer

    You cannot access FTP with an reseller account. You must add an (email) user account and check the administrator checkbox for this account to upload files with FTP to this website.

Share This Page