Fubar in Ubuntu; now im getting all sorts of errors

Discussion in 'HOWTO-Related Questions' started by Mangelo, Feb 26, 2006.

  1. Mangelo

    Mangelo New Member

    Summary: Kernel Panic - not syncing: can't allocate buffers is my error problem, symptoms and the way i came to this final solution (haha...final problem) are proceeding, but for the sake of sparing the readers, that aforementioned error message is (i think) what i have problems with. thanks in advance if you do brave this entire thing!

    Heyos all, brand new linux user here! And i need to recover from a total fubar'd newbie mistake! This is the only time i ever touched linux, after (literally) having grown up with a windows system (3.1 and above)...I just had an old machine and a copy of ubuntu 5.10, so im taking myself on a joy ride...

    unfortunatly it got cut short. really quickly.

    I was following the HOW-TO at http://www.howtoforge.com/perfect_setup_ubuntu_5.10 . Every time i had to open a file to edit, i used gedit in its gui (does it even have a command line interface? i have no clue...is command line interface even the right vocabulary? *shrug*), but anywho... the gui loaded up every time i tried to run it... then i got up to page 3 of the how to, and the steps where you run apt-get to install the packages.

    "Edit /etc/apt/sources.list And Update Your Linux Installation" That is the first step i did that im pretty sure the mistake occured somewhere, because I never tried to open up any other window until I noticed what happened....

    I run through the exact tutorial, copy and pasting into the terminal the apt-get commands to update, upgrade, install ssh, install the other softwrae, and set the quota... then i tried to follow onto the next step, which would be to edit fstab... so in keeping with my windows-native way, i go focus on the (already open) file browser...double click on fstab...and wait for gedit to load up like its been doing (BTW i am logged into ubuntu this entire time AS root, not just root permissions through command line. newbie mistake #1, haha). well...gedit doesnt load up! so i try "gedit" in the terminal...and i get the error:

    Re: Xlib: connection to ":0.0" refused by server - Xlib: No protocol specified.

    so im like "wtf m8"... i do a little searching online (through this windows machine sitting next to the now - fubard' linux box), find its something with drawing windows on the screen..kinda makes sense cause no gui is loading up (i tried to open running services, package manager, file browser, nothing opened).... so i have still no luck... then a light comes on above my head.

    i'll just undo everything i've done up until the point i know xlib was working fine! so i type apt-get remove quota

    then i type apt-get remove ssh openssh-server

    then...i take a look at this nice big line of pure and utter nonsense to me

    apt-get install binutils cpp cpp-4.0 fetchmail flex gcc gcc-4.0 libarchive-zip-perl libc6-dev libcompress-zlib-perl libdb4.3-dev libpcre3 libpopt-dev linux-kernel-headers lynx m4 make ncftp nmap openssl perl perl-modules unzip zip zlib1g-dev autoconf automake1.9 libtool bison autotools-dev
    little did i know that therefore typing

    apt-get remove binutils cpp cpp-4.0 fetchmail flex gcc gcc-4.0 libarchive-zip-perl libc6-dev libcompress-zlib-perl libdb4.3-dev libpcre3 libpopt-dev linux-kernel-headers lynx m4 make ncftp nmap openssl perl perl-modules unzip zip zlib1g-dev autoconf automake1.9 libtool bison autotools-dev

    would screw me as it did...cause all of a sudden i saw terminal output saying "removing ubuntu" ! now that struck me as odd..but i dont know much about linux..maybe it was a duplicated name...shortcut? nothing... then i noticed everything else started to get removed....

    i havent panicked at this point...it will remove everything and i'll just use apt-get to rebuild the interface...it would be hard, but i have the resources(internet) to find out how to do it...

    then the damn thing freezes on it!! (its not the best of computers, never had been). now every time i turn on the computer, my bios (phoenix bios 4.0) runs properly, finds everything correctly (including my cd drive..i thought i can just resotre off the ubuntu cd, apparntly i cant). it hangs up a bit on loading GRUB...and even if i press esc into the menu and select the ubuntu (recovery mode) module, it returns to me the same error

    Kernel Panic - not syncing: can't allocate buffers. and ya...thats it... i cant do anything past that. I tried to boot with the installation cd (and right now as i type thjis i got the idea to try the live cd...so as i type im gonna let that try to boot itself up...results will come as they happen), and just reinstall the whole thing, but simply presseing "enter" for base system, or typing "server" to install the bare bones leads me to the same error message, and a freeze in cpu activity.

    I just want to get a fresh install of linux, and preferably with any distro that is good at doing file serving throughout my windows based household (3 other windows computers) and yes, i do realize that i was following an isp tutorial, meanwhile i should have been following the samba tutorial instead..i noticed that (after) the whole process started going horribly wrong on me, thats why i want a fresh install so i can follow that one properly.

    any help would be GREATLY appreciated! thanks in advance

    edit: forgot to include the results of trying the Live cd instead of install....same exact problem -_-
  2. falko

    falko Super Moderator Howtoforge Staff

    I suggest you do a clean re-install and do everything on the command line instead of through the GUI. For editing files on the command line, you can use vi. Have a look here to learn how you use it: http://www.howtoforge.com/faq/12_15_en.html
    And you should do all the steps as root!
    Starting from page three of the "Perfect Setup", you can do everything from your Windows box (that is, after you've installed SSH). Just install PuTTY ( http://www.chiark.greenend.org.uk/~sgtatham/putty/download.html ) on your Windows box, and log in to your Linux box, and then you can copy and paste the commands from the tutorial to the command window.
  3. Mangelo

    Mangelo New Member

    many thanks, i bookmarkd the page and i'll check it out when i get home from a computer show, any questions i'll throw them into this thread. thanks again!
  4. Mangelo

    Mangelo New Member

    new update to the problem

    ya, i get to a command prompt that says "grub>", when i press ESC during grub loading, and press "c" for command prompt...and im still totally lost on what to do, and how to do it...i would love to do a fresh install, and if i have to i'll build the entire interface from the ground up (what better way to learn the system?), but i cant even begin a reinstall process, this menu prompt (the "grub>" promp isnt accepting the few basic commandsi know
  5. falko

    falko Super Moderator Howtoforge Staff

    You're on the boot loader's shell (grub) because your system doesn't seem to start. In your BIOS you should set that the system boots from CD so that you can do a clean re-install of the whole system.
  6. Mangelo

    Mangelo New Member

    i hit every dead end in the world, until i ran a memtest. it was returning all sorts of red at me!!! so i just pulled out the bad stick of ram, and now it works...the only problem is i now have the bare bones of the kernel (command line). that link telling how to edit via command line helped, once i knew whjat i was doing!! i just rebuilt the kernel through command line, and started on the (correct) howto (i realized the partition and installs are all the same, so i just started from the editing of the hosts file, interfaces networking file, etc etc etc... now i ran into another snag as described in this thread


    but at least i got a working command line, and everything i do now doesnt return any errors, so i know the kernel is working fine, i just have to learn it from scrattcchh (which doesnt really bother me, its the whole point of this excersize to begin with

Share This Page