FYI OpenSuse 13.2

Discussion in 'Installation/Configuration' started by muekno, Nov 24, 2015.

  1. muekno

    muekno Active Member HowtoForge Supporter

    till likes this.
  2. muekno

    muekno Active Member HowtoForge Supporter

    Dis upgrade all my ISPConfig multiserver test enviorement and my ISPConfig multiserver production enviorement to 13.2 with the method descriped above. Reason, 13.1 run out of support soon, 13.2 gives me an other year. Did nor upgrade to 42.1 on 3 reasons, 1. my production servers running on ESXi where the hardware allows only 32 bit systems, the 42.1 system gets me still too much patches, for me its too new for production, 3. I have not enough experience with 42.1 and ISPConfig.
    Yes I had minor problems with upgrade but easy solvable.
    First Apace did not start wit suexc problem, easily solved with "chmod 4755 /usr/sbin/suexec2"
    Second Apache did not start https did not find installed certificates, solved Update install newcrtificate and puts a symbolic link certs in /etc/ssl/ to the new certificates, but renames the old certs folder to certs.rpmnew, did delete the link and rename certs folder, where my official certificates are. this did also solve that squirrelmail could not connect on port 111 as all mail ist configured to use ssl. Solve problem postfix errors too.
    Third mariadb mysql did not come up, but postet a warning. I had to force upgrade the databases. had no problem with the force upgrade, all my ISPConfig an TYPO3 databases are running fine.
    Dis this the last day, so only short term experiences, but I have a very good feeling.

    Hope this helps SuSe users

  3. muekno

    muekno Active Member HowtoForge Supporter

    Update: dis recognize that mails are received by postfix but not relayed to my final mailserver. Manualy sending was ok, so no firewall or dns problem. Found out amavis did not start. Research found
    doing "sa-update" on the command line did the job, amavis could be startet, stuck mails are delivered after postqueue -f.


    hoping to find no other problems
  4. muekno

    muekno Active Member HowtoForge Supporter

    sugestion: clean up the list of softwarerepositories, easiest using yast
    update: with 13.1 I could load the ISPConfig Administration pages in my browser and they stayed open sometimes days, that means as long as my pc and browser where up. Now with 13.2 I am loged out from the administration after a relative short time and I have to log in again.
    Maybe Till can say something to that, was it a bug in 13.1 that I was not loged out or is it ab bug in 13.2
    further I got mails from cron, see here seams to be a bug, that should be fixed long time, but still the old rpm ist delivered

Share This Page