Gallery 2 on Debian Lenny/ISPConfig3

Discussion in 'Installation/Configuration' started by techman83, Feb 1, 2010.

  1. techman83

    techman83 New Member

    Gallery 2 on Debian Lenny/ISPConfig3 [SOLVED]

    Hi All,

    Got what will hopefully be a quick one. Just done a fresh install with Debian 5, Ispconfig3 with Falko's Perfect Setup guide. Which got me up and running nicely.

    What I'm having a problem with is that unless I put my Galleries data directory under web/ (which isn't recommended) Gallery 2 comes up with an error:

    Error: Some files and or directories in your storage directory are not writeable by the webserver user. 
    Run chown -R webserverUser /var/www/ OR 
    run chmod -R 777 /var/www/
    I've tried owning it with the right "web:client" and also the apach user "www-data" and even trying 777 (shouldn't be necessary). I don't think SElinux is enabled as running a "ls -Z" just lists question marks next to all the directories.

    My only guess is that something in Apache is preventing Gallery from accessing any files outside of web/.

    Any help/general prods in the right direction would be much appreciated.

    Last edited: Feb 1, 2010
  2. damir

    damir New Member

    Do you have right paths in G2 config file?
  3. techman83

    techman83 New Member

    Yep, I can confirm that. When I moved it under web/ it worked fine. I even tried moving it to /g2data with correct perms, just to take all the complexity out, to no avail.



    EDIT: To note, above error shows the working path, but I moved it back out after confirming I could get it to work somewhere. Re-tested with path outside web/, still got error
    Last edited: Feb 1, 2010
  4. till

    till Super Moderator Staff Member ISPConfig Developer

    The access for files outside of the website dir is forbidden for security reasons. If you want this, you will have to edit the php open_basedir path in the vhots template and the cgi and fcgi starter templates.
  5. techman83

    techman83 New Member

    That's definitely it. I changed the vhost file under sites enabled and it worked. I'm assuming if I make any changes to the site from the panel, it will overwrite those changes, but it'll do for the time being until I have time to learn how to make a custom template and apply it to that site (if it's possible).
  6. till

    till Super Moderator Staff Member ISPConfig Developer

    As I posted above, you should have changed the vhost template and not the vhost file as all changes that you did in the vhost file get removed automatically. The templates are in /usr/local/ispconfig/server/conf/
  7. techman83

    techman83 New Member

    Thanks, Found and done!

Share This Page