grub + SATA RAID1 + IDE

Discussion in 'Installation/Configuration' started by ryoken, Feb 9, 2006.

  1. ryoken

    ryoken New Member

    ive recently got Debian 3.1 "Sarge" installed, but am confused as to why grub is giving me different results depending on whether i'm in the actual bootloader, or logged into Linux.

    when i run "find /boot/grub/stage1" in the grub bootloader (by pressing "c" to enter the CLI mode), it shows:


    but when i run i've logged into my Debian machine and type the following:

    1) grub
    2) find /boot/grub/stage1

    it shows these results:


    why is there such a disparity between what grub thinks during the bootloader time and after its logged in? is it something to do with if so, how do i fix it? can this be remedied within Debian Installer so I don't need to apply any post-fixes?

    FYI, I have two SATA drives setup as RAID 1 (/dev/sda and /dev/sdb) using md and one standalone IDE drive (/dev/hda) that is not part of any RAID array. and yes, i do need grub to be installed into the mbr of both SATA drives.

    another side-effect of this problem is that when debian-installer asks if grub should be installed into the MBR, and you select Yes, then it gets installed into the MBR of the IDE HDD. as this is not what i wanted, ive manually selected No and typed in /dev/sda. But this, I think, has caused grub to get confused - as illustrated at the top of this post. To clear up any confusion, the missing drive at the top of this post (hd1,0) and (hd0,0) respectively, is of course the IDE drive - since I didn't want it to be booted from - and has been confirmed using the "geometry" tests in grub.

    What's the best solution to this problem? Has anyone else encountered this issue? Looking forward to your responses!
  2. ryoken

    ryoken New Member

    so no one has seen/heard about this problem before? :confused:

Share This Page