Hardware compatibility List (HCL)

Discussion in 'Desktop Operation' started by conductive, Sep 13, 2021.

  1. conductive

    conductive Member HowtoForge Supporter

    Does anybody know where a current Linux HCL is?

    I wanted to build a Ryzen 5600X but am having difficulties finding a motherboard.

    I tried a MSI B550-a Pro.
    The Debian installation appeared to go OK but It does not boot.

    Any suggestions appreciated.

  2. Taleman

    Taleman Well-Known Member HowtoForge Supporter

    I know only what Internet Search Engines find with
    linux hardware compatibility list
    You do not say what version of Debian you are installing nor what exact installation media you are using. You did get the installation media from https://www.debian.org/distrib/ and not from some shady third party?
    If installed Linux does not boot, I would check BIOS settings, perhaps reset to factory default and update BIOS to latest.
    BIOS settings are important so the device starts booting from the device where you installed LInux.
  3. conductive

    conductive Member HowtoForge Supporter

    HCL's used to be an integral part of Linux development. Unfortunately the current HCL's appear to be outdated
    Debian 11 directly form the Debian mirrors. This is not the problem here installed from a minimal .iso hundreds of times.
    I talked to the motherboard mfg. and was told that the Bios is not seeing the boot device.

    The problem here is to find a motherboard with a 550 chipset that is compatible with Linux.

    Does anybody have any motherboard recommendations that will work with the AMD 5600X
  4. ahrasis

    ahrasis Well-Known Member HowtoForge Supporter

    This board MSI B550-A Pro should work with Ryzen 5600X naturally. What is your exact problem, usb or hard drive not detected?
  5. conductive

    conductive Member HowtoForge Supporter

    The M2.nvme drive is detected but it will not see a boot device.
    Grub2 should be properly installed on the M2.nvme
  6. ahrasis

    ahrasis Well-Known Member HowtoForge Supporter

    Try booting from other drive.
  7. conductive

    conductive Member HowtoForge Supporter

    Thanks for the little nudge I needed to confirm that all should work. The board mfg. was not very positive toward Linux.

    On this install I tried LVM and it asks a question "force UFEI" it was defaulted to no so I just accepted it.

    I reinstalled Debian 11 and changed "force UFEI" to yes and all is good now. I still have a few things wo work out but it appears that this hardware will work fine.
    ahrasis likes this.

Share This Page