HELP! mail problems still!!

Discussion in 'Installation/Configuration' started by Griff, May 24, 2006.

  1. Griff

    Griff New Member


    Whenever a client tries to send an email they keep getting an auth error i have remoted there machines and set it up for authorisation but it's saying incorrect username/password i have checked through the forums but could not see a fix for this in any of the posts.

    I am running Debian from Perfect Setup Guide.

    they can recieve there POP emails perfectly fine and i am able to send mails using my master domain account but it's the other domains that cannot send i even setup a domain as a test to see if it was something in there config and i copied the settings from my domain to the test domain but it's still coming up with the same error.... I have tried username "web<num>_<name>@domain" and "web<num>_<name>@masterdomain" aswell as "web<num>_<name>" but to no avail.

    All help greatly appreciated.

    Thanks in advance.



    [email protected] | "Linux is not user-friendly!"
    | "It _is_ user-friendly. It's just not
    #include <std_disclaimer.h> | ignorant-friendly and idiot-friendly."
    #include <rest_of_sig.h> | -- Unknown
  2. falko

    falko Super Moderator ISPConfig Developer

    What's the exact error message? What's in your mail log?
  3. Griff

    Griff New Member

    Sending of message failed:

    The message could not be sent because connecting to SMTP server failed. the server may be unavailable or refusing smtp connections. Please verify that your SMTP server setting is correct and try again, or else contact your network administrator.

    which logs would you like to see? postfix or user mail logs?
  4. falko

    falko Super Moderator ISPConfig Developer

    Make sure your firewall doesn't block port 25. What's the output of
    netstat -tap

    It's the same log file, usually in the /var/log directory.
  5. Griff

    Griff New Member


    Mail.log.ispconfig linked below as it was too long for a quote and wouldn't let me attach it.

  6. falko

    falko Super Moderator ISPConfig Developer

    If you find an error in mail.log, please post it here.
    What's the output of
    iptables -L
  7. Griff

    Griff New Member

    lol the mail log hasn't been touched since december apparently .. above is the outcome of iptables -L

    Thanks Again for all your help
  8. Griff

    Griff New Member

    Sorry that wasn't very helpful.

    the mail.log file is totally empty the only mail.* file with anything at all in is mail.log.ispconfig ... Hope this helps to clear that up a bit.

    according to the mail.log.ispconfig the last time the log was touched was december last year and then it died ... more info is on the actual log.
  9. falko

    falko Super Moderator ISPConfig Developer

    Is your public IP address?
    You don't have a DNS record for
  10. Griff

    Griff New Member

    Yes that's the servers ip address... i tried to remove before but FTPD kept sending server errors so i ended up putting it back... so should i create a co-domain or how will this work? sorry for this but my Tech used to do all of this but he's recently passed away so i'm having to learn V quickly.
  11. Griff

    Griff New Member

    sorry for late reply have been working all day and night... i'm always trying to find a way to get access to my sites but the work's server don't allow internet access just Intranet
  12. falko

    falko Super Moderator ISPConfig Developer

    You can add to /etc/hosts for now. That replaces the missing DNS record.
  13. Griff

    Griff New Member

    That's whats in there currently? but it's still not letting me send the emails
  14. falko

    falko Super Moderator ISPConfig Developer

    What's in your mail log now when you try to send an email?
  15. Griff

    Griff New Member

    The mail log is still empty...


    that seems wrong to me... all of the other mail logs are empty even mail.err and and mail.warn.

    Still the same error occuring when trying to send an email.
  16. till

    till Super Moderator Staff Member ISPConfig Developer

    I guess the log is a bit old "Dec 13 01:21:45", or is the date set wrong on your server?

    The ISPConfig log is always a backup copy of your mail log, if the maillog save option in ISPConfig is enabled.
  17. Griff

    Griff New Member

    just done a quick check in the server settings and mail logs should be saved in /var/log/mail.log and Save Log is ticked so yep it should be logged but it's not... now i'm really baffled...?
  18. Griff

    Griff New Member

    also just checked some of the other files Mail.warn.0 and that's also got a repeat of the mail.log.ispconfigsave in there... does that error above not mean that postfix isn't running?

    i've done ./etc/init.d/postfix start and got

  19. falko

    falko Super Moderator ISPConfig Developer

    The restart shoud have got logged in /var/log/mail.log. Do you see it there?
  20. Griff

    Griff New Member

    nope still don't see anything in the mail.log it's still empty... shall i try to do the restart using ispconfig?

Share This Page