Help - Where's all my space gone?

Discussion in 'Technical' started by Mr Blek, Feb 1, 2008.

  1. Mr Blek

    Mr Blek New Member

    I'm running SUSE. Today I ran out of disk space on a 150gig hd. I don't have much on the drive so I did the following commands as root:

    du -s -h
    titan:/ # du -s -h
    du: cannot access `./backups/Thursday.sql.gz': Permission denied
    du: cannot access `./backups/Friday.sql': Permission denied
    I tried to delete the above to files as root but it wouldn't let. ls gave a permission denied.


    titan:/ # df -h
    Filesystem            Size  Used Avail Use% Mounted on
    /dev/hda2             148G  123G   25G  84% /
    udev                  499M  112K  499M   1% /dev
    du = 3.0G
    df = 123G

    Surely something is wrong there? I thought a fsck was in order, so i executed the command

    titan:/ # fsck.reiserfs --fix-fixable /dev/hda2
    Do you want to run this program?[N/Yes] (note need to type Yes if you do):Yes
    reiserfsck --fix-fixable started at Fri Feb  1 16:43:14 2008
    Partition /dev/hda2 is mounted with write permissions, cannot check it
    titan:/ # 
    How do I go about fixing the problem? / is mounted as /dev/hda2 so I can't see how I can unmount the whole filesystem. Is there another way to do fix the inconsistency? I've tried setting the flag in /etc/fstab but that hasn't worked.
    Last edited: Feb 1, 2008
  2. thecaoticone

    thecaoticone New Member

    If you have a live cd ( like Gentoo ) you can boot from it and try to run the fsck.reiserfs commands.
    I recently had to do this with my personal pc after a power supply failure.
    Last edited: Feb 2, 2008
  3. Mr Blek

    Mr Blek New Member

    Thanks that worked. This was on a root server so I had to boot into the provided rescue system run fsck.reiserfs --rebuild-tree

    Took absolutely ages (best part of 8 hours) but everything is back to normal.

Share This Page